Nomear intervalos, encontrar uma interseção de linha-coluna

Novembro 2016



Assim, vejamos uma <souligne>tabela de distâncias entre cidades</souligne >; as colunas são chamadas Lyon e Marselha, as linhas Paris e Lille e, nós queremos, só escrevendo Lille e Marselha, saber a distância entre elas.

Nomear as linhas e colunas de uma planilha, automaticamente.


No nosso exemplo, a tabela ocupa o intervalo A3:C5, que nós selecionamos e, nas guias "Fórmulas / Nomes Definidos ", vamos escolher "A partir da seleção" mantendo as opções padrão: "Linha do alto" e " Coluna da esquerda". Veja como é simples criar nomes a partir da seleção!

Digitar a fórmula de pesquisa intuitiva na interseção da linha coma coluna


No Excel (em qualquer versão), o operador de inteseção é o espaço.

Para calcular a distância entre Lille e Marselha, basta digitar a fórmula na célula B7
=Lille Marselha
ou a fórmula
=Marselha Lille
Basta separar o nome da linha e o da coluna com um espaço.
Nos dois casos aparece o resultado [ 1000 ] ...

Utilizar uma fórmula com as funções ÍNDICE e CORRESP


A técnica anterior é adequada para pequenas tabelas, para evitar o aumento excessivo de nomes de intervalo.
Assim, para grandes tabelas, usamos uma fórmula com a função de pesquisa ÍNDICE;
Os argumentos desta função (<ital> a referência da linha e da coluna
) serão dados pela função CORRESP que vai identificá-los
  • na coluna de títulos, a linha em questão,
  • na linha de títulos, a coluna em questão.

Com o título da linha (Lille) em A12 e o da coluna (Lyon) em B12, esta fórmula se escreve :
= ÍNDICE($B$4:$C$5; CORRESP(A12;$A$4:$A$5;0); CORRESP(B12;$B$3:$C$3;0))

Observação

  • Como em qualquer criação de nome, não se deve começar com um número, colocar um espaço ou um caractere reservado como / \ #! ? : *@
  • Em versões mais antigas do Excel, fazer "inserção / nomes / criar..." e marcar " linha do topo" e " coluna da esquerda".


Tradução feita por Lucia Maurity y Nouira

Veja também :
Este documento, intitulado « Nomear intervalos, encontrar uma interseção de linha-coluna »a partir de CCM (br.ccm.net) está disponibilizado sob a licença Creative Commons. Você pode copiar, modificar cópias desta página, nas condições estipuladas pela licença, como esta nota aparece claramente.