Excel - Ativar uma lista de validação de acordo com certos critérios

Maio 2017

É possível neutralizar ou, inversamente, ativar uma lista de validação com base em critérios (valor numérico ou de texto em uma célula ou grupo de células, etc).

Para simplificar ou encurtar fórmulas, sobretudo se os valores-alvo estiverem em uma planilha diferente da planilha com a lista de validação, é aconselhável nomear o intervalo de células que contém esses dados. Por exemplo, esses dados se encontram na planilha chamada "Plan2". Colocar o intervalo em questão (Plan2 intervalo A1:A20) sublinhado e nomeá-la (Nome/Definir nome) exemplo Titi.

Antes de criar a lista de validação, é imperativo que a condição critério seja TRUE (Verdadeiro).

Se, por exemplo, a ativação da lista de validação estiver sujeita ao conteúdo de uma célula que no exemplo abaixo é a célula B5, entre um valor X nesta célula.

Na célula D3, queremos criar a lista de validação que exibirá os dados do intervalo chamado Titi. Normalmente, nós teríamos digitado como fórmula de validação = Titi, neste caso, vamos digitar = SE (B5 <>"";Titi;"")
Agora é possível testar a lista de validação mas, apenas quando a célula B5 estiver em branco.

É possível pensar de outra maneira, integrando o teste na definição do intervalo chamado, desta vez, de "lista", para evitar as interferências com o intervalo chamado "Titi"
=SE(Plan1!$B$5<>"";DESLOC(Plan2!$A$1;1;;COUNTA(Plan2!$A:$A)-1);"")

Com base neste princípio, a acessibilidade da lista de validação de pode ser submetida a qualquer tipo de controle. Suponhamos que queiramos usar a lista de validação quando a soma dos valores do intervalo A1:A20 for inferior ou igual a 20.

Neste caso, a condição "true" (verdadeira) é inferior ou igual a 20, incluindo as células vazias que retornarão ao valor zero quando a soma for feita.

A fórmula para a criação da lista de validação será
=SE(SOMA($A$1:$A$20)<=20;Titi;"")

No caso da acessibilidade da lista de validação ser submetida a uma soma mínima tal como 20 ou mais, é obrigatório digitar no intervalo A1 a A20 um valor, pelo menos, igual ou superior a 20, ou a soma do intervalo preencherá esta condição.

Em seguida, você poderá criar a lista de validação e a fórmula será
=SE(SOMA($A$1:$A$20)>=20;Titi;"")

A partir deste exemplo é possível imaginar qualquer tipo de condição.

Baixe o arquivo de exemplo (em francês): http://cjoint.com/?BKzoUyiDQdq

Tradução feita por Lucia Maurity y Nouira

Veja também

Artigo original publicado por . Tradução feita por pintuda. Última modificação: 26 de novembro de 2012 às 14:27 por pintuda.
Este documento, intitulado 'Excel - Ativar uma lista de validação de acordo com certos critérios', está disponível sob a licença Creative Commons. Você pode copiar e/ou modificar o conteúdo desta página com base nas condições estipuladas pela licença. Não se esqueça de creditar o CCM (br.ccm.net) ao utilizar este artigo.