Como trabalhar com a função PROCH (HLOOKUP) no Excel

Julho 2017


Referências (Procedimento do PROCH (Excel 2003 e Excel 2007): você deve selecionar as referências na sua planilha. Neste exemplo, a sua referência é a $A$1:$F$4. Depois de selecioná-la, clique em Inserir - Nome - Definir (Para este exemplo, o nome dado foi PRODUTOS). Excel 2007: a atribuição do nome é feita através do menu Fórmulas.

Local onde os dados encontrados aparecerão

Neste exemplo:

J1=Termo a ser procurado
J3=Descrição encontrada (coluna 2 da nossa planilha)
J5=Quantidade encontrada (coluna 3 da nossa planilha)
J7=Preço encontrado (coluna 4 da nossa planilha)

Fórmulas

A sintaxe de base da função PROCH é:
= PROCH (valor_pesquisa;tabela_matriz;no_index_lig;valor_aproximado)
(=HLOOKUP(lookup_value,table_array,row_index_num,range_lookup)

(Tutorial PROCH)

J3

=PROCH ($J$1;PRODUTOS;2;FALSO)
Sendo mais simples, parta do conteúdo da célula H1, procuramos na primeira linha da tabela PRODUTOS, a coluna que inicia com o mesmo conteúdo, e extraímos o valor colocado na segunda linha; FALSO, isto indica que estamos procurando uma correspondência exata. Para não ter a mensagem #N/A, se não foi encontrado nada, utilizamos a fórmula seguinte e Desconhecido aparecerá na célula do resultado.

=SE(FORNA(PROCH($J$1;PRODUTOS;2;FALSO));"Desconhecido";PROCH($J$1;PRODUTOS;2;FALSO))
(Veja a função SE ou IF aqui)

Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCH($J$1;PRODUTOS;2;FALSO);"Desconhecido")

J5

=PROCH ($J$1;PRODUTOS;3;FALSO)
Para ser simples, partindo do conteúdo da célula H1, procuramos na primeira linha da tabela PRODUTOS, na coluna que começa com este conteúdo, e extraímos o valor colocado na terceira linha; FALSO, indica que estamos procurando uma correspondência exata. E, para não obter a mensagem #N/A, se nada foi encontrado, a seguinte fórmula e "Desconhecido" aparecerá na célula do resultado.

=SE(FORNA(PROCH($J$1;PRODUTOS;3;FALSO));" Desconhecido "; PROCH ($J$1;PRODUTOS;3; FALSO))
Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCH($J$1;PRODUTOS;3;FALSO);"Desconhecido")

J7

=PROCH($J$1;PRODUTOS;4;FALSO)
Para ficar mais simples e partindo do conteúdo da célula H1, procuramos na primeira linha da tabela PRODUTOS, a coluna que comece com o mesmo conteúdo, e extraímos o valor colocado na 4º linha: FALSO, indica que estamos procurando uma correspondência exata. Para não receber a mensagem #N/A, se nada foi encontrado, utiliza-se a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.

=SE(FORNA(PROCH($J$1;PRODUTOS;4;FALSO);"Desconhecido";PROCH($J$1;PRODUTOS;4;FALSO))

Com o Excel 2007 existe uma fórmula mais curta: =SEIERRO(PROCH($J$1;PRODUTOS;4;FALSO);"Desconhecido")
Observação: na fórmula, definimos como FALSO se você quiser procurar o valor preciso (# N/A se não for encontrado) e, VERDADEIRO se o valor for igual ou inferior mais próximo; neste caso, a lista de valores deve estar organizada.
Se esta configuração for esquecida, seu valor padrão é VERDADEIRO.

Foto: © LINE ICONS shutterstoock.Medium.

Veja também

Artigo original publicado por . Tradução feita por pintuda. Última modificação: 7 de outubro de 2016 às 10:44 por ninha25.
Este documento, intitulado 'Como trabalhar com a função PROCH (HLOOKUP) no Excel', está disponível sob a licença Creative Commons. Você pode copiar e/ou modificar o conteúdo desta página com base nas condições estipuladas pela licença. Não se esqueça de creditar o CCM (br.ccm.net) ao utilizar este artigo.