Tutorial Função PROCV (VLOOKUP)

Dezembro 2016

Você deve selecionar as referências em sua planilha. Neste exemplo, a sua referência é $A$2:$D$10. Depois de selecioná-la, clicar em Inserir - Nome - Definir (Para este exemplo, dei o nome de CAMPOS).

Excel 2007: a definição do nome é feita através do menu Fórmulas.

Local onde os dados encontrados aparecerão

Neste exemplo:

H1= Termo a ser procurado
H4= Descrição encontrada (coluna 2 da nossa planilha)
H6= Quantidade encontrada (coluna 3 da nossa planilha)
H8= Preço encontrado (coluna 4 da nossa planilha)

Fórmulas

A sintaxe de base da função
PROCV é
:
=PROCV(valor_pesquisa;tabela_matriz;no_index_lig;valor_aproximado)
(=VLOOKUP(lookup_value,table_array,row_index_num,range_lookup)

H4

=PROCV($H$1;CAMPOS;2;FALSO)
Para ser mais claro, partindo do conteúdo da célula H1, procuramos na primeira linha da tabela CAMPOS, a coluna começando com esse conteúdo, e extraímos o valor colocado na segunda linha; FALSO, mostra que estamos procurando uma correspondência exata, e evitando a mensagem #N/A, se nada foi encontrado, foi utilizada a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.

=SE(FORNA(PROCV($H$1;CAMPOS;2;FALSO));"Desconhecido";PROCV($H$1;CAMPOS;2;FALSO))
Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCV($H$1;CAMPOS;2;FALSO);"Desconhecido")

H6

=PROCV($H$1;CAMPOS;3;FALSO)
Simplificando, partindo do conteúdo da célula H1, procuramos na primeira linha da tabela CAMPOS, a coluna começando com esse conteúdo, e extraímos o valor colocado na terceira linha; FALSO, prova que estamos procurando uma correspondência exata. Para não visualizar a mensagem #N/A, se nada foi encontrado, a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.

=SE(FORNA(PROCV($H$1;CAMPOS;3;FALSO));"Desconhecido";PROCV($H$1;CAMPOS;3;FALSO))
Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCV($H$1;CAMPOS;3;FALSO);"Desconhecido")

H8

=PROCV($H$1;CAMPOS;4;FALSO)

Simplificando, partindo do conteúdo da célula H1, procuramos na primeira linha da tabela CAMPOS, a coluna começando com esse conteúdo, e extraímos o valor colocado na quarta linha; FALSO, diz que estamos procurando uma correspondência exata. Para evitar que a mensagem #N/A, se exiba se nada foi encontrado, utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.

=SE(FORNA(PROCV($H$1;CAMPOS;4;FALSO));"Desconhecido";PROCV($H$1;CAMPOS;4;FALSO))
Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCV($H$1;CAMPOS;4;FALSO);"Desconhecido")

Nota: na fórmula, definimos como FALSO se você quiser procurar o valor exato (# N/A se não for encontrado) e, VERDADEIRO se o valor for igual ou inferior mais próximo; neste caso, a lista de valores deve estar organizada. Se a configuração for deixada de lado, seu valor padrão é VERDADEIRO.

Foto: © LINE ICONS shutterstoock.Medium.

Veja também

Artigo original publicado por . Tradução feita por pintuda. Última modificação: 7 de outubro de 2016 às 10:45 por ninha25.
Este documento, intitulado 'Tutorial Função PROCV (VLOOKUP)', está disponível sob a licença Creative Commons. Você pode copiar e/ou modificar o conteúdo desta página com base nas condições estipuladas pela licença. Não se esqueça de creditar o CCM (br.ccm.net) ao utilizar este artigo.