Denunciar

Cálculo de Média Aritmética no Excel [Resolvido]

Faça uma pergunta spectre1999 2Posts quarta 18 de maio de 2016Data de inscrição 18 de maio de 2016 Última visita - Última respostas em 18 Mai 2016, as 11:48
Bom dia,

A dúvida que tenho é a seguinte:

Tenho 4 células nas quais são entrados os valores e a quinta célula daria-me a média aritmética destes 4 valores, ou seja, a soma dos valores divido por 4, mas o problema é que, caso uma dessas células estivesse vazia, a fórmula ajustasse automaticamente para fazer a divisão por 3 e não por 4... Caso haja somente 2 valores, fazer a divisão por 2... Existe a possibilidade de fazer isso? Se sim, é possível ser feito com fórmula ou com vba?

Abraço!
Maurício
Ver mais 
Útil
+2
moins plus
Maurício, Bom dia.

A FUNÇÃO MÉDIA do Excel faz exatamente isto o que você precisa.

Suponha que os seus dados estão de A1 até D1 (4 células)

Faça: E1 --> =MÉDIA(A1:D1)

Preencha quantas células desejar.
O resultado será sempre a SOMA das células preenchidas dividido pela QUANTIDADE de células preenchidas.

Era isso o que você queria?
Eu espero ter ajudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
spectre1999 2Posts quarta 18 de maio de 2016Data de inscrição 18 de maio de 2016 Última visita - 18 Mai 2016, as 11:48
É isso mesmo. Muito obrigado.
Ajudou muito!

Abraço!
Maurício
Responder
Adicionar comentário

Os membros recebem mais respostas que os usuários anônimos.

Quem é membro tem acompanhamento detalhado de suas perguntas.

Os membros têm direito a opções adicionais.

Você ainda não é membro?

Inscreva-se, é gratuito e não leva mais de um minuto!