Denunciar

Excel - fórmulas [Resolvido]

Faça uma pergunta marceloguimaraes.sp 4Posts quinta 13 de outubro de 2016Data de inscrição terça 1 de novembro de 2016 Última visita - Última respostas em 13 Out 2016, as 14:28
Caros amigos,

Tenho tentado há algum tempo mas sem sucesso, pois não sou um conhecedor muito profundo de excel.

Vamos lá, preciso desenvolver uma fórmula que me dê o seguinte resultado:

de 0 até 800 km = 0 dias
de 801 até 1600 km = 1 dias
de 1601 até 2400 km = 2 dias

Para explicar: Meu carro roda até no máximo 800 km/dia, ou 10 horas.
Então até os 800 km eu preciso de um dia para rodar e assim por diante.
Este valor servirá para calcular o quanto terei de hospedagem para o motorista.

Desde já agradeço.
Ver mais 
Útil
+1
moins plus
marceloguimaraes.sp, Bom dia.

Como você não explicou como é o layout da sua planilha fica mais difícil de ajudá-lo de forma conclusiva.

No Excel é possível fazer os cálculos de várias maneiras.
A fórmula abaixo permite você calcular os dias de forma contínua além da sua tabela, isto é, qualquer kilometragem.

Suponha:
A1 --> Qtde Kilometros

C1 --> Dias --> Fórmula
=SE(A1<=0;0;SE(MOD(A1;800)=0;INT(A1/800)-1;INT(A1/800)))

Era isso o que você queria?
Eu espero ter ajudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
marceloguimaraes.sp 4Posts quinta 13 de outubro de 2016Data de inscrição terça 1 de novembro de 2016 Última visita - 13 Out 2016, as 14:09
Desculpe Marcílio.
Vou tentar explicar melhor:

Tenho um motorista que pode rodar por dia 800 km no máximo.

Acima disto ele terá que pernoitar.

Então penso em criar uma tabela da seguinte forma:

De 0 até 800 km = 0 pernoite + 0 refeição extra
De 801 até 1600 km = 1 pernoite + 1 refeição extra
De 1601 até 2400 km = 2 pernoite + 2 refeições extras

Estes valores se relacionam diretamente com o custo final de minha viagem.

Desta forma:

Uma viagem de 800 km não me adiciona nada em meu orçamento, porém uma de 1600 me adicionaria 1 pernoite e 1 refeição a mais, impactando diretamente no meu lucro.
Responder
marceloguimaraes.sp 4Posts quinta 13 de outubro de 2016Data de inscrição terça 1 de novembro de 2016 Última visita - 13 Out 2016, as 14:16
Exatamente isto que me enviou Mazzaropi, muito obrigado pela ajuda.
Responder
Adicionar comentário
Útil
+1
moins plus
marceloguimaraes.sp,

Obrigado pelo feedback.
Fico feliz em ter ajudado
--
Belo Horizonte, Brasil.
Marcílio Lobão
Adicionar comentário
Útil
+0
moins plus
Veja esta página:
http://br.ccm.net/s/excel+formulas
Adicionar comentário

Os membros recebem mais respostas que os usuários anônimos.

Quem é membro tem acompanhamento detalhado de suas perguntas.

Os membros têm direito a opções adicionais.

Você ainda não é membro?

Inscreva-se, é gratuito e não leva mais de um minuto!