Dúvida Excel - PROCV / ÍNDICE+CORRESP

Fechado
David_Benner Posts 7 Data de inscrição sexta 2 de fevereiro de 2018 Status Membro Última visita 28 de março de 2018 - 28 mar 2018 às 11:16
Mazzaropi Posts 1985 Data de inscrição segunda 16 de agosto de 2010 Status Contribuinte Última visita 24 de maio de 2023 - 28 mar 2018 às 18:17
Bom dia, gostaria de tirar uma dúvida com vocês, utilizo em minhas planilhas essas fórmulas para pesquisar informações em um banco de dados, só que percebi que ele sempre mostra a primeira opção da linha encontrada indo de cima pra baixo, existe alguma maneira dessa pesquisa ser feita de baixo pra cima e a primeira linha encontrada me mostrasse as informações?

O motivo é porque esse banco de dados começa com as informações mais antigas e vai indo para as mais novas e atualizadas e não podemos classificar do mais recente pro antigo, pois existe algumas informações entre esse banco de dados que não podem sair do seu devido local, agradeço desde já.

2 Respostas

Mazzaropi Posts 1985 Data de inscrição segunda 16 de agosto de 2010 Status Contribuinte Última visita 24 de maio de 2023 590
28 mar 2018 às 12:03
David_Benner, Boa tarde.

"...começa com as informações mais antigas e vai indo para as mais novas e atualizadas..."

Como você identifica que a informação é mais antiga ou não?

Existe uma data para a sua referência ou algum código sequencial ou outra coisa qualquer?

Até para sugerir algo para lhe ajudar é importante para nós, conhecer o layout do seu arquivo. Senão fica muito difícil a gente ficar sugerindo coisas sem nenhuma referência real.

Você também pode salvar um modelo do seu arquivo em algum site gratuito, www.sendspace.com ou outro qualquer e colocar o link para download aqui.
Lembre-se de mostrar os dados que você tem e colocar como precisa que seja o resultado final.

Tenha um bom dia!
--
Belo Horizonte, MG - Brasil.
Marcílio Lobão
0
David_Benner Posts 7 Data de inscrição sexta 2 de fevereiro de 2018 Status Membro Última visita 28 de março de 2018
28 mar 2018 às 17:18
Fiz um exemplo, segue o link da planilha

https://www.sendspace.com/file/jrohbq

O exemplo que fiz foi baseado em uma corretora de seguros, onde as informações que consta nas primeiras linhas são os dados dos clientes e o seu devido vencimento, um ano depois ela irá renovar o seguro, com isso a mesma pessoa que está lá em cima, estará novamente nas linhas abaixo, com isso teria uma duplicidade de informações na hora que for fazer a busca, as fórmulas utilizadas irá encontrar os dados antigos, pois ela busca de cima pra baixo, gostaria que ela pesquisasse de baixo para cima, pois resolveria o problema que temos atualmente, uma preocupação seria no campo situação do seguro, onde utiliza uma fórmula baseada na data de hoje menos o fim do seguro pra verificar se o mesmo está ativo, caso contrário ele verifica nas linhas de baixo para ver se o mesmo cpf repete, caso sim ele identifica que o mesmo renovou, caso contrário o seguro está vencido (que facilitaria na hora de pesquisar os seguros vencidos).
0
Mazzaropi Posts 1985 Data de inscrição segunda 16 de agosto de 2010 Status Contribuinte Última visita 24 de maio de 2023 590
28 mar 2018 às 18:17
David_Benner, Boa noite.

Tente usar:

F3 -->
=SEERRO(MÁXIMO(SE(B8:B13=C3;H8:H13));"NÃO CADASTRADO")
MATRICIAL

G3 -->
=SEERRO(ÍNDICE(I8:I13;SOMARPRODUTO((B8:B13=C3)*(H8:H13=F3)*LIN(I8:I13))-7);"NÃO CADASTRADO")

Apliquei no seu arquivo modelo:
https://www.sendspace.com/file/ge7pi3

Era isso o que você queria?
Eu espero ter ajudado.
--
Belo Horizonte, MG - Brasil.
Marcílio Lobão
0

Assine nossa newsletter!

Assine nossa newsletter!
Junte-se à comunidade