Faça uma pergunta »

Criar rapidamente um planejamento de férias simples [Excel]

Julho 2015

  • A1 : Entrar as férias de 2008
  • A2 : Entrar Nome e Sobrenome
  • A3 à Ax : Entrar o nome das x pessoas a administrar
  • B1 : Entrar 01/05/08 ; Formato/Célula/Número/Personalizado/Tipo ddd
  • B2 : Entrar =B1 ; Formato/Célula/Número/Personalizado/Tipo dd mmm
  • Incrementar B1: B2 para a direita, em 184 colunas (até 31 de Outubro); para isso, selecionar B1 e B2, puxar a alavanca no canto inferior direito e, no ícone de opções de cópia incrementada, escolher Incrementar uma série
  • Selecionar a folha inteira e ativar a Paginação condicional com Valor da célula ="c" e Formato de fonte azul escuro + motivo de preenchimento azul claro
  • Se preciso, digitar esta legenda no final do quadro: c : dia de folga (exibido em azul)

O tabalho de base está concluído. Para cada funcionário, digite a letra « c » nas casas correspondentes aos dias de folga: Eles vão aparecer em azul!

Veja o exemplo de um documento Excel, depois de seguir as etapas acima: Planejamento de férias

Agora só falta ajustar a apresentação ao seu gosto, por exemplo:
  • Bordas (grade pontilhada, de preferência, para evitar o efeito "grade de prisão")
  • As linhas 1 e 2, em fonte Arial Narrow ou Agency FB de tamanho 8 ou 9; linha 2, orientação vertical
  • Reduzir a largura das colunas (largura de cerca de 4,00, seja 33 pixels)
  • Adicionar em todas as células uma regra de validação com uma mensagem de entrada (em vez de escrever uma legenda fixa na parte inferior da tabela)
  • Adicionar uma segunda condição de formatação para os sábados, domingos e feriados

Suplemento para calcular os dias úteis [Excel 2007 apenas]. Se você quiser usar este programa para contar o número de dias úteis, de cada empregado, adicione uma marca para sábados, domingos e feriados.
  • inserir uma linha 3
  • digitar "F" para cada dia não trabalhado (fim-de-semana ou feriado)
  • em GD4 digitar =NB.SI.ENS(B4:GC4;"c";B$3:GC$3;"") e copiar para baixo.


Veja o documento Excel 2007 com o complemento de cálculo dos dias úteis: Planejamento de férias - 2

Preenchimento automático.

Depois da coluna A, inserir 3 novas colunas Data início, Data fim e Dias úteis.
  • as 2 novas colunas B e C devem ser formatadas em data dd/mm ; digitar as datas de férias para cada empregado.
  • dar à coluna B o nome de início, à coluna C o nome do fim , à linha 2 o nome data e à linha 3 o nome F.
  • digitar em F1 a fórmula =E1+1 e copiar à direita nas 184 colunas do planejamento; dar à célula E1 o nome data.
  • na célula E4 (primeira casa da grade-planejamento) digitar a fórmula =SE (E (data>=início; data<=fim; NÃO (F="F"));"C";"") a ser copiado em todas as casas. É esta fórmula que inscreverá F ou C nas casas interessadas respectivamente, para os dias não trabalhados e para as folgas.
  • na célula D4, teremos a fórmula =NB.SI(E4:GF4;"C"), a ser copiado para baixo. Se a coluna GG se tornar inútil, remova-a.
  • para animar a apresentação do planejamento, a partir da E4, aplicar uma Formatação Condicional com A fórmula é</souligne > =E$3="F" e um <souligne>preenchimento de cor e, em seguida, estender esta MFC a todas as outras casas do planejamento, à direita e embaixo.



Tradução feita por Lucia Maurity y Nouira

Para uma leitura offline, é possível baixar gratuitamente este artigo no formato PDF:
Criar-rapidamente-um-planejamento-de-ferias-simples-excel.pdf

Veja também

Na mesma categoria

Faire rapidement un planning de congés avec Excel
Por Raymond PENTIER em 11 de junho de 2008
Artigo original publicado por Raymond PENTIER. Tradução feita por pintuda.
Este documento, intitulado « Criar rapidamente um planejamento de férias simples [Excel] »a partir de CCM (br.ccm.net) está disponibilizado sob a licença Creative Commons. Você pode copiar, modificar cópias desta página, nas condições estipuladas pela licença, como esta nota aparece claramente.