4
Obrigado

Algumas palavras de agradecimento nunca são demais.

Como usar a Função SE com mais de 7 imbricações no Excel

Veja nesse artigo as ações que você aplicar sobre uma função SE para que seja possível criar fórmulas com mais de sete condições.




O uso de múltiplas condições em uma função SE recebe o nome de função SE composta. Veja nesse artigo como construir uma função SE composta. Abaixo, você verá opções para disponibilizar um grande número de condições em uma mesma fórmula.

Com dados de texto

Tomemos como célula-fonte a A2 na qual serão digitados valores de um (1) a cinquenta e seis (56) no formato de texto. Para facilitar o acompanhamento, os resultados estarão no formato numérico. Para progredir no número de condições, basta terminar o valor se falso com 0 (zero) e iniciar uma nova sobreposição precedida do sinal + (mais):

=SE(A2="um";1;SE(A2="dois";2;SE(A2="três";3;SE(A2="quatro";4;SE (A2="cinco";5;SE(A2="seis";6;SE(A2="sete";7;0)))))))+SE(A2="oito";...

Com dados numéricos

Dessa vez, vamos usar como célula-fonte a A8, os dados no formato numérico de 1 a 4 e os resultados no formato de texto. Aqui, conclua o valor se falso de cada conjunto de condições com "" (vazio) e reinicie uma sobreposição com o sinal &:

=SE(A8=1;"um";SE(A8=2;"dois";SE(A8=3;"três";SE(A8=4;"quatro";SE(A8=5;"cinco";SE(A8=6;"seis";SE(A8=7;"sete";"")))))))&SE(A8=8; ...

Com campos

Esse método consiste em criar campos contendo a fórmula condicional. Para começar, ative a célula que exibirá o resultado. Depois, crie o primeiro campo (Nome/Definir um nome) com o exemplo do campo chamado Form1. Em se refere a, digitar a fórmula e terminar com a condicional tradicional valor se falso = FALSO:

=SE(Plan1!A2="um";1;SE(Plan1!A2="dois";2;SE(Plan1!A2="três";3;SE(Plan1!A2="quatro";4;SE(Plan1!A2="cinco";5;SE(Plan1!A2="seis";6;SE(Plan1!A2="sete";7;FALSO)))))))


Continuar criando um novo campo chamado Form2 e digitar a seguinte fórmula para continuar a imbricação condicional:

=SE(Plan1!A2="oito";8;SE(Plan1!A2="nove";9;SE(Plan1!A2="dez";10;SE (Plan1!A2="onze";11;SE(Plan1!A2="doze";12;SE(Plan1! A2="treze";13;SE (Plan1!A2="catorze";14;FALSO)))))))


Idem até o oitavo campo, se necessário. Na célula ativa D5, digitar uma fórmula condicional simples, mas fazendo referência aos campos nomeados:

=SE(Form1;Form1;SE(Form2;Form2;SE(Form3;Form3;SE(Form4;Form4;SE(Form5;Form5;SE(Form6;Form6;SE(Form7;Form7;SE (Form8;Form8;""))))))))


As possibilidades tornam-se bem maiores. Temos sete condições por campo (para não saturar as possibilidades do Excel) x 8, ou seja, 56 condicionais. Também é possível reiniciar novas cascatas como nos dois primeiros exemplos, nos mesmos critérios, o que aumenta o número de possibilidades:

SE(Form8;Form8;""))))))))&SE(Form9; ou SE(Form8;Form8);0))))))))+SE (Form9)


Esse último método é interessante porque permite testar diversas células, inclusive em várias planilhas, ou criar uma cascata de células, ou planilhas. É possível obter um número ilimitado de condicionais com este último método.

Com células de revezamento

Esse método permite obter um número ilimitado de condicionais usando células (ocultas) em uma coluna. Nesse exemplo, na primeira célula (C13) será digitada a primeira fórmula de sete condicionais, terminada pelo valor se falso referindo-se à célula que contém a segunda fórmula condicional (C14):

=SE(Plan1!A11="um";1;SE(Plan1!A11="dois";2;SE(Plan1!A11="três";3;SE(Plan 1!A11="quatro";4;SE(Plan 1! A11="cinco";5;SE(Plan 1! A11="seis";6;SE(Plan 1!A11="sete";7; C14)))))))


Na célula C14, deve ser inserida a seguinte fórmula condicional com o valor se falso apontando para o endereço da célula que contém a fórmula (C15):

=SE (Plan1! A11="oito";8;SE(Plan1!A11="nove";9;SE(Plan1!A11="dez";10;SE(Plan1! A11="onze"11;SE(Plan1!A11="doze";12;SE(Plan1!A11="treze"13;SE(Plan1!A11="catorze";14; C15)))))))


Serão usadas tantas células quanto necessárias, sem limitação. O resultado será retomado por uma simples fórmula, como a D11, e fará referência à primeira célula condicional = C13.

Planilha única e fórmula simplificada

Quando as células testadas estiverem na mesma planilha, você pode diminuir a fórmula dos campos substituindo Plan1! A2 pelo endereço da célula A2 ou em referência absoluta $A$2.

Foto: © dennizn - Shutterstock.com

Veja também

Este documento, intitulado 'Como usar a Função SE com mais de 7 imbricações no Excel', está disponível sob a licença Creative Commons. Você pode copiar e/ou modificar o conteúdo desta página com base nas condições estipuladas pela licença. Não se esqueça de creditar o CCM (br.ccm.net) ao utilizar este artigo.

0 Comentário