Função SE no Excel: para que serve e como usar

A função SE do Excel permite inserir condições lógicas entre valores. Esta função apresenta-se desta forma: SE uma coisa for verdadeira, ENTÃO faça algo, SE NÃO (caso contrário), faça outra coisa.


Para que serve a função SE

A função SE serve para responder perguntas simples, usando a palavra SE para determinar uma condição por meio de fórmulas lógicas, bastando para tanto seguir algumas regras de sintaxe. Esta função serve, acima de tudo, para facilitar o tratamento das comparações de dados no Excel.


A função SE na sua forma mais simples (uma coisa ou outra) retornará dois resultados. Um se a primeira comparação for um resultado verdadeiro e outro se a primeira comparação for um resultado falso. Algo é BRANCO ou não, algo é GRANDE ou não, alguma coisa está ABERTA ou não e assim por diante. Ela pode avaliar o valor e o texto (argumento) de uma célula, mas também avaliar códigos de ERRO apresentados pelo Excel.

Na sua forma composta (ou aninhada), ela pode conter várias instruções SE, ou seja, pode conter mais de duas instruções e usar operadores matemáticos como < (menor que); > (maior que); = (igual); <> (diferente), para executar outros cálculos. Assim, é possível aninhar funções SE para realizar diferentes tipos de comparações.

As funções SE compostas podem ter de três a 64 funções SE diferentes. Porém, apesar de ser tecnicamente possível fazer isso, a utilização de várias funções SE aninhadas cria uma complexidade de lógica e sintaxe que trará problemas e grande dificuldade de entendimento das regras e na alteração delas se for preciso. Para casos de muitas opções, existem funções mais avançadas que fazem esse trabalho com eficiência. PROC, PROCV, PROCH e a combinação de ÍNDICE + CORRESP são apenas algumas possibilidades.

Como usar a função SE

A função SE no Excel apresenta a seguinte estrutura:
=SE (Condição a verificar; Ação se VERDADEIRO; Ação se FALSO)
. Veja abaixo um exemplo de uso dessa fórmula:

Em uma fila, 10 crianças estão vestidas com camisetas AMARELAS ou AZUIS. Vamos distribuir pirulitos e balas para as crianças conforme a cor das camisetas. SE a camiseta da criança for AMARELA, ela recebe um pirulito, SE NÃO for amarela, (só pode ser AZUL), ENTÃO ela recebe duas balas. Como aplicar essa lógica em uma planilha Excel?

Na imagem abaixo, vemos:
A1:A10: nomes das crianças;
B1:B10: cores das camisetas que cada criança está vestindo (amarela ou azul);
C1:C10: a função SE colocará os textos ‘Pirulito’ ou ‘Duas balas’ dependendo da cor da camiseta presente na mesma linha da coluna B. Cor amarela deve aparecer Pirulito, cor azul deve aparecer Duas balas.

Como existem somente duas possibilidades de cores das camisetas, podemos utilizar a função SE perguntando por apenas uma das cores.

Na coluna ‘C’ da planilha, inserimos =SE(B1=”Amarela” ; “Pirulito” ; “Duas balas”):


Para usar a fórmula em toda a coluna basta usar a alça de preenchimento (não é preciso refazer a sintaxe a cada linha).

Dica: o cifrão ($), presente na imagem, serve para travar linhas ou colunas para quando for utilizar a alça de preenchimento (cruz pequena no canto inferior direito da célula) para arrastar a fórmula para baixo ou para o lado sem alterar a referência da célula de comparação.

Erros de sintaxe na fórmula

Atente para a sintaxe da fórmula, considerando que um espaço a mais ou a menos, a falta de aspas, bem como a falta de lógica da instrução pode ocasionar erros. Veja abaixo alguns erros comuns na aplicação da função SE no Excel.


Erros específicos recorrentes no retorno da função SE: aparecer #NOME? na célula significa, geralmente, que o texto da fórmula está incorreto. Caso apareça 0 (zero) na célula é provável que esteja faltando um argumento na fórmula (a menos que zero seja uma das respostas esperadas). Por exemplo, se a fórmula tiver que retornar ‘valor_se_verdadeiro’ e ‘valor_se_falso’, deve-se colocar os argumentos para cada possibilidade.

Veja como podem acontecer erros por causa da sintaxe mal construída. O exemplo foi publicado no fórum do CCM:

Sintaxe com erro:
=SE(K3<>"Pendente";"Finalizada");SE(K3="Pendente";(C3+10))
. A fórmula retorna um erro. Lembre-se que a estrutura da fórmula é a seguinte:
=SE (Condição a verificar; Ação se VERDADEIRO; Ação se FALSO)
.

Para dar certo, a sintaxe deverá, portanto, ser escrita assim:
=SE(K3="Pendente" ; (C3+10) ; "Finalizada")
.

Assim, a primeira sintaxe errou na lógica (ordem dos argumentos). Note que há duas possibilidades: K3 está pendente ou não. Se K3 está pendente é preciso fazer um deternimado cálculo (C3+10), se não estiver pendente, está finalizado. Daí a fórmula: =SE(K3="Pendente" [Condição a verificar]; (C3+10) [Ação se VERDADEIRO]; "Finalizada" [Ação se FALSO]).

Função SE composta

Como dito acima, a função SE composta é quando existem várias condições a serem levadas em conta. Veja um exemplo a seguir:


Uma empresa vai premiar a equipe de vendedores no mês de aniversário da loja com alguns prêmios de acordo com o valor vendido por cada vendedor. Para isso, foi estabelecida uma tabela de prêmios para fins de transparência e justiça.

Quem vender até R$ 1.000, ganhará uma Mochila Personalizada (Prêmio A); quem vender de R$ 1.000 a R$ 3.000, ganhará um conjunto de Calça e Agasalho (Prêmio B); quem vender de R$ 3.000 a R$ 6.000, ganhará um Tênis (Prêmio C) e quem vender mais de R$ 6.000, ganhará todos os prêmios da promoção mais um par de ingressos para a Final da Superliga Masculina de Vôlei (Prêmio D).

Para selecionarmos os prêmios que determinado vendedor irá receber, basta olharmos para o nome e valor das vendas do mesmo em uma lista e verificarmos em qual faixa de vendas ele está localizado para saber qual prêmio ele deve ganhar.

Em uma planilha temos:
A1:A10: nome dos vendedores;
B1:B10: valor das vendas no mês de aniversário da loja;
C1:C10: prêmio que irá receber de acordo com as vendas.

Na célula C1, inserimos =SE(B1<=1000; "Prêmio A"; SE(E(B1>1000;B1<=3000); "Prêmio B"; SE(E(B1>3000;B1<=6000); "Prêmio C"; "Prêmio D" ))):


Foto: © Microsoft.
Publicado por ninha25. Última modificação: 31 de maio de 2018 às 07:36 por Bruna.CCM.
Este documento, intitulado 'Função SE no Excel: para que serve e como usar', está disponível sob a licença Creative Commons. Você pode copiar e/ou modificar o conteúdo desta página com base nas condições estipuladas pela licença. Não se esqueça de creditar o CCM (https://br.ccm.net/) ao utilizar este artigo.
Excel: formatação condicional ilimitada
Excel: colorir células sob determinadas condições