1
Obrigado

Algumas palavras de agradecimento nunca são demais.

Colocar duas condições em uma mesma célula no Excel

Nesse breve artigo, veja como fazer para colocar duas condições diferentes em uma mesma célula no Excel, dando, portanto, opções para que a fórmula chegue ao seu resultado final.



A função SE é uma das mais importantes do Excel. Com ela, é possível criar condições para os valores exibidos em determinada célula. No seu contexto, o usuário tem a possibilidade de adicionar duas ou mais condições em uma mesma célula, no que receber o nome de função SE composta.

Formato da função SE composta

Fazendo isso, você amplia o leque de valores que podem ser retornados em uma célula e, como toda fórmula do Excel, automatiza ações que tomariam tempo e teriam grau de erro mais elevado. O formato básico de função SE composta é o seguinte:


=SE("condição";valor;SE("condição";resultado;SE("condição";resultado)))


Perceba que como parênteses são abertos durante a descrição da condição, eles devem ser todos fechados ao final da fórmula.

Exemplo de aplicação da função SE composta

Vamos agora ver um exemplo de como aplicar uma função SE composta. No nosso caso, vamos pensar em uma escola que possui uma listagem de professores, funcionários e alunos e pretende estabelecer um código para cada um deles. Os professores receberão o código 1, funcionários, código 2 e alunos, código 3:



Para evitar o trabalho braçal, vamos lançar mão da função SE composta. Assim, vamos aplicar a função à primeira linha da tabela. Para isso, selecione a célula B1 e insira a seguinte fórmula:

=SE(A1="Professor";1;SE(A1="Funcionário";2;SE(A1="Aluno";3)))


Como já sabemos que o valor de A1 é Professor, o valor retornado na célula B1 será 1. Agora, para replicar a mesma condição em todas as demais linhas da tabela, basta que você clique no canto inferior direito da célula B1, arraste até o fim da tabela e solte:



Feito isso, os códigos agora aparecerão em todas as linhas, conforme a imagem abaixo:



Foto: © Dzmitry Kliapitski - 123RF.com
Veja também
Este documento, intitulado 'Colocar duas condições em uma mesma célula no Excel 2007', está disponível sob a licença Creative Commons. Você pode copiar e/ou modificar o conteúdo desta página com base nas condições estipuladas pela licença. Não se esqueça de creditar o CCM (br.ccm.net) ao utilizar este artigo.

Assine nossa newsletter!

Receba toda semana o melhor conteúdo

Assine nossa newsletter!