Funções lógicas SE, E, OU, NÃO

Novembro 2016

Esta é mais uma dica sobre o uso das funções SE, E, OU, NÃO. Ela foi colocada aqui para ser encontrada mais rapidamente pelos fãs das nossas Dicas. Veja também o site da Microsoft.


Função SE

Função SE isolada

Se a nota em A1 for superior ou igual a 19, então exibir 20, se não exibir A1 expresso pela fórmula: =SE(A1>=19;20;A1)
Se o dado em A1 for Reset, subtrair 10%, caso contrário, manter A1 expresso pela fórmula: =A1*SE(A1="Reset";1-10%;1)


Funções SE associadas

Se a nota em A1 for superior a 12, então exibir Continue, se A1 for superior a 18, então adicionar Muito bom, senão, exibir Regular. Mas se A1 for inferior ou igual a 12, então exibir Melhorar, expresso pela fórmula:
=SE(A1>12;"continue," & SE(A1>18;"Muito bom";"Regular");"Melhorar")
ou pela fórmula
=SE(A1<12;"Melhorar";SE(A1<18;"continue, Regular";"continue, Muito bom"))


Se a nota em A1 for inferior à 4, então exibir Nulo; se A1 estiver entre 4 e 8, então exibir Médio; se A1 estiver entre 8 e 12, então exibir Médio; se A1 estiver entre 12 e 16, então exibir Bom; senão, exibir Muito bom, expresso pela fórmula:
=SE(A1<4;"Nulo";SI(A1<8;"Regular";SI(A1<12;"Médio";SI(A1<16;"Bom";"Muito bom"))))

Função E


Exibir Senhora condessa! se todas essas condições se realizarem: A2 (sexo)=mulher, B2 (estado civil)=casada, C2 (esposa)=conde e D2 (chamada)=presente; senão, exibir Bom dia, expresso pela fórmula:
=SE(E(A2="mulher";B2="casada"; C2="conde"; D2="presente"); "Senhora condessa!"; "Bom dia")

Função OU


Exibir Piloto se A3 contiver um dos seguintes dados: avião, fórmula 1, moto; exibir Motorista se A3 contiver carro ou obras; senão, exibir ?, expresso pela fórmula:
=SE(OU(A3="avião";A3="fórmula 1"; A3="moto");"Piloto"; SE(OU(A3="carro";A3="obras");"Motorista";"?"))

Função NÃO

A fórmula =SE(ENT(A3)=A3;"inteiro";"decimal") também pode ser escrita assim:
=SE(NÃO(ENT(A3)=A3);"decimal";"inteiro")
assim como:
=SE(A4<>"francês";"estrangeiro";"europeu")
é equivalente a:
=SE(NÃO(A4="francês");"estrangeiro";"europeu")

Combinações

As funções E, OU, NÃO são, frequentemente, associados à função SE. O interesse para aquele que utiliza uma planilha, é definir uma tabela de verdade e desenhar um organograma representando o algoritmo do problema a ser resolvido, combinando as quatro funções e garantindo o respeito entre os parênteses e os ponto-e-vírgulas, para que a fórmula funcione. Esta fórmula deve ser testada sistematicamente, tentando todos as possibilidades e os valores limites das variáveis.

Veja também

Função SE: mais de 7 imbricações no Excel
Fórmulas básicas do Excel

Veja também :
Este documento, intitulado « Funções lógicas SE, E, OU, NÃO »a partir de CCM (br.ccm.net) está disponibilizado sob a licença Creative Commons. Você pode copiar, modificar cópias desta página, nas condições estipuladas pela licença, como esta nota aparece claramente.