Excel: criar um planejamento de férias para funcionários

Todos os anos, precisamos criar horários para treinamento, programação, acompanhamento, atribuição de cargos, etc. Nesta dica, vamos ver como mostrar feriados, por exemplo.


Planejamento básico

A1: digitar as férias de 2008 (por exemplo);
A2: digitar Nome e Sobrenome;
A3 à Ax: digitar o nome das pessoas em questão;
B1: digitar, por exemplo, 01/05/08; Formato/Célula/Data/Personalizado/Tipo ddd;
B2: digitar =B1; Formato/Célula/Data/Personalizado/Tipo dd mmm;
Incrementar B1:B2 à direita, em 184 colunas (até 31/10, por exemplo); para isso, selecionar B1 e B2, arrastar a cruzinha no canto inferior direito e, no ícone de opções de cópia incrementada, escolher Incrementar uma série;
Selecionar a folha inteira e ativar a Paginação condicional com o valor da célula ="f" e Formato de fonte azul escuro + motivo de preenchimento azul claro;
Se necessário, digitar esta legenda no final do quadro: <bold>v: dia de folga (exibido em azul).


O trabalho de base acabou. Para cada funcionário, digite a letra v (vacation) nas casas correspondentes aos dias de folga, eles vão aparecer em azul.

Como ajustar a apresentação a seu gosto

Bordas (grade pontilhada, de preferência, para evitar o efeito ‘grade de prisão’). As linhas 1 e 2, em fonte Arial Narrow ou Agency FB de tamanho 8 ou 9; linha 2, orientação vertical. Reduzir a largura das colunas (largura de cerca de 4,00, ou seja, 33 pixels). Adicionar em todas as células uma regra de validação com uma mensagem de entrada (em vez de escrever uma legenda fixa na parte inferior da tabela). Adicionar uma segunda condição de formatação para os sábados, domingos e feriados.

Suplemento para calcular os dias úteis (Excel 2007 apenas)

Se você quiser usar este programa para contar o número de dias úteis de cada empregado, adicione uma marca para sábados, domingos e feriados. Inserir uma linha 3. Digitar "V" para cada dia não trabalhado (em inglês, vacation - fim de semana ou feriado),
Em GD4, digitar
=NB.SI.ENS(B4:GC4;"c";B$3:GC$3;"")
e copiar para baixo.

Preenchimento automático

Depois da coluna A, inserir 3 novas colunas Data início, Data fim e Dias úteis. As 2 novas colunas B e C devem ser formatadas em data dd/mm/aa. Digitar as datas de férias para cada empregado. Dar à coluna B o nome ‘Data de início’, à coluna C o nome ‘Data de fim’, à linha 2 o nome ‘Data’ e à linha 3 o nome ‘F’. Digitar em F1 a fórmula =E1+1 e copia-la, à direita, nas 184 colunas do planejamento. Dar à célula E1 o nome data.

Na célula E4 (primeira casa da grade-planejamento) digitar a fórmula
=SE(E (data>=início; data<=fim; NÃO (F="F"));"V";"")
a ser copiado em todas as casas. É esta fórmula que inscreverá F ou V nas casas interessadas, respectivamente, para os dias não trabalhados e para as folgas. Na célula D4, teremos a fórmula
=NB.SI(E4:GF4;"V")
, a ser copiado para baixo. Se a coluna GG se tornar inútil, remova-a. Para animar a apresentação do planejamento, a partir da E4, aplicar uma Formatação condicional com a fórmula <bcodeold>=E$3="F"</code> e um preenchimento de cor e, em seguida, estender esta MFC a todas as outras casas do planejamento, à direita e na parte inferior.

Foto: © Microsoft.
Artigo original publicado por Raymond PENTIER. Tradução feita por pintuda. Última modificação: 1 de dezembro de 2017 às 13:17 por Pedro.CCM.
Este documento, intitulado 'Excel: criar um planejamento de férias para funcionários ', está disponível sob a licença Creative Commons. Você pode copiar e/ou modificar o conteúdo desta página com base nas condições estipuladas pela licença. Não se esqueça de creditar o CCM (https://br.ccm.net/) ao utilizar este artigo.
Excel: deletar o conteúdo de certas células
VBA - Mensagem para fazer o usuário esperar