Ajuda no Excel

Resolvido/Fechado
WermuthAnderson - 8 out 2015 às 12:01
WermuthAnderson
Posts
1
Data de inscrição
quinta 8 de outubro de 2015
Status
Membro
Última visita
8 de outubro de 2015
- 8 out 2015 às 20:17
Bom dia,

Preciso da ajuda de vocês.

Na célula A1 eu posso ter 3 tipos de dados:
- data (01/01/2015)
- data com asterísco (01/01*)
- ponto (.)

Para cada uma das opções, preciso que seja preenchida na célula A2 um resultado diferente, por exemplo:
Célula A1="23/02/2015" Célula A2="T"
Célula A1="23/02*" Célula A2="R"
Célula A1="." Célula A2="."

Como eu poderia resolver isso?

1 resposta

Mazzaropi
Posts
1963
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
25 de abril de 2022
584
8 out 2015 às 14:24
WermuthAnderson, Boa tarde.

Se nas suas células SOMENTE tiverem dados nestes três formatos utilize esta fórmula:
=SE(ÉNÚM(A1);"T";SE(A1=".";A1;"R"))

Se ALÉM destes tipos de dados também tiver células em BRANCO ou outros conteúdos utilize esta fórmula:
=SE(ÉNÚM(A1);"T";SE(ÉNÚM(SEERRO(LOCALIZAR("~*";A1);""));"R";SE(A1=".";A1;"")))

Fiz um exemplo para você poder avaliar:
http://speedy.sh/3sbSz/08-10-2015-pt-Kioskea-Formatos-diferentes-na-mesma-Celula-OK.xlsx

Era isso o que você queria?
Eu espero ter ajudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
1
WermuthAnderson
Posts
1
Data de inscrição
quinta 8 de outubro de 2015
Status
Membro
Última visita
8 de outubro de 2015

8 out 2015 às 20:17
Mazzaropi

Obrigado pela colaboração.

Era isso mesmo que eu precisava.
0

Assine nossa newsletter!

Assine nossa newsletter!