Formula Excel Mês [Resolvido/Fechado]

Denunciar
Posts
7
Data de inscrição
quinta 11 de maio de 2017
Status
Membro
Última visita
terça 6 de junho de 2017
-
Posts
1829
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
30 de maio de 2018
-
Olá pessoal!

Como faço para que, quando uso a formula "Mês" as células em branco na coluna que ainda será preenchida com a data, não seja remetido o mês de janeiro?? Considerando que já coloquei a formula "Mês" na coluna inteira!

Ex.

Data Mês
12/05/17 Maio
(em branco) Janeiro

Muito obrigada!!!

4 respostas

Posts
1829
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
30 de maio de 2018
511
rosabsilva, Bom dia.

Uma pergunta sobre o seu caso.
Você usou a função MÊS na coluna B buscando a data da coluna A e saiu o mês por extenso??

Quando você usa essa função a resposta é numérica, isso é, o número do mês. 5 para Maio, 12 para dezembro e 1 para janeiro.

MAS.... se por acaso você após digitar essa fórmula na coluna B você formatar a coluna como DATA: mmmm para mostrar o nome do mês, aí então acontecerá um ERRO, pois aparecerá o nome do mês considerando o dia do ano na contagem do EXCEL.

10/01/2017 --> aparecerá --> Janeiro

05/06/2017 --> aparecerá --> Janeiro

31/12/2017 --> aparecerá --> Janeiro

Como o maior mês é dezembro, que é 12, o EXCEL interpreta que você quer saber o mês do 12° dia do ano, que realmente ainda é janeiro.

Para evitar isso basta fazer uma coisa muito simples:

Suponhamos:

A1 --> 10/01/2017

B1 --> =SE(A1="";"";A1)
Formate então a coluna B para DATA --> Personalisado --> mmmm

Era isso o que você queria?
Eu espero ter ajudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
Posts
7
Data de inscrição
quinta 11 de maio de 2017
Status
Membro
Última visita
terça 6 de junho de 2017

Boa tarde, Mazzaropi!

Obrigada por ter respondido!!

Na verdade o que eu gostaria é:

Coluna A
Mês com a formula

Coluna B
Propostas

Coluna C
Datas

quando vou fazer a contagem do numero de propostas que tive em cada mes, o mes de janeiro fica com informação incorreta, pois a formula considera celulas em branco (sem a data ainda informada) como janeiro!!! E eu gostaria de deixar a coluna A com varias linhas já preparadas com a formula do mes!! É possivel??!!

maio P2292 09/05/2017
maio P2293 09/05/2017
maio P2294 09/05/2017
janeiro
janeiro
janeiro
janeiro
Posts
1829
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
30 de maio de 2018
511
rosabsilva, Boa tarde.

Apesar da minha mensagem, você não explicou como você consegue a palavra MAIO através da sua fórmula.

Supondo que a sua data esteja na coluna C:

Experimente fazer assim:


A1 --> =SE(C1="" ; "" ; sua fórmula para MÊS)

Por favor, nos diga se funcionou agora como você deseja.
Espero ter ajudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
Posts
7
Data de inscrição
quinta 11 de maio de 2017
Status
Membro
Última visita
terça 6 de junho de 2017

Boa tarde.


Funcionou!!

Muito obrigada!!
Posts
1829
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
30 de maio de 2018
511
rosabsilva, Bom dia.

Obrigado pelo feedback.

Fico feliz em ter ajudado você.

Tenha um ótimo dia.
--
Belo Horizonte, Brasil.
Marcílio Lobão