Formula Excel Mês

Resolvido/Fechado
rosabsilva Posts 7 Data de inscrição quinta 11 de maio de 2017 Status Membro Última visita terça 6 de junho de 2017 - 11 mai 2017 às 10:13
Mazzaropi Posts 1967 Data de inscrição segunda 16 de agosto de 2010 Status Contribuinte Última visita 3 de outubro de 2022 - 17 mai 2017 às 13:37
Olá pessoal!

Como faço para que, quando uso a formula "Mês" as células em branco na coluna que ainda será preenchida com a data, não seja remetido o mês de janeiro?? Considerando que já coloquei a formula "Mês" na coluna inteira!

Ex.

Data Mês
12/05/17 Maio
(em branco) Janeiro

Muito obrigada!!!

4 respostas

Mazzaropi Posts 1967 Data de inscrição segunda 16 de agosto de 2010 Status Contribuinte Última visita 3 de outubro de 2022 584
11 mai 2017 às 11:29
rosabsilva, Bom dia.

Uma pergunta sobre o seu caso.
Você usou a função MÊS na coluna B buscando a data da coluna A e saiu o mês por extenso??

Quando você usa essa função a resposta é numérica, isso é, o número do mês. 5 para Maio, 12 para dezembro e 1 para janeiro.

MAS.... se por acaso você após digitar essa fórmula na coluna B você formatar a coluna como DATA: mmmm para mostrar o nome do mês, aí então acontecerá um ERRO, pois aparecerá o nome do mês considerando o dia do ano na contagem do EXCEL.

10/01/2017 --> aparecerá --> Janeiro

05/06/2017 --> aparecerá --> Janeiro

31/12/2017 --> aparecerá --> Janeiro

Como o maior mês é dezembro, que é 12, o EXCEL interpreta que você quer saber o mês do 12° dia do ano, que realmente ainda é janeiro.

Para evitar isso basta fazer uma coisa muito simples:

Suponhamos:

A1 --> 10/01/2017

B1 --> =SE(A1="";"";A1)
Formate então a coluna B para DATA --> Personalisado --> mmmm

Era isso o que você queria?
Eu espero ter ajudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
2
rosabsilva Posts 7 Data de inscrição quinta 11 de maio de 2017 Status Membro Última visita terça 6 de junho de 2017
11 mai 2017 às 13:46
Boa tarde, Mazzaropi!

Obrigada por ter respondido!!

Na verdade o que eu gostaria é:

Coluna A
Mês com a formula

Coluna B
Propostas

Coluna C
Datas

quando vou fazer a contagem do numero de propostas que tive em cada mes, o mes de janeiro fica com informação incorreta, pois a formula considera celulas em branco (sem a data ainda informada) como janeiro!!! E eu gostaria de deixar a coluna A com varias linhas já preparadas com a formula do mes!! É possivel??!!

maio P2292 09/05/2017
maio P2293 09/05/2017
maio P2294 09/05/2017
janeiro
janeiro
janeiro
janeiro
0

Assine nossa newsletter!

Assine nossa newsletter!