Cálculo de Média Aritmética no Excel [Resolvido/Fechado]

spectre1999 2 Posts quarta 18 de maio de 2016Data de inscrição 18 de maio de 2016 Última visita - 18 mai 2016 às 11:18 - Última resposta: spectre1999 2 Posts quarta 18 de maio de 2016Data de inscrição 18 de maio de 2016 Última visita
- 18 mai 2016 às 11:48
Bom dia,

A dúvida que tenho é a seguinte:

Tenho 4 células nas quais são entrados os valores e a quinta célula daria-me a média aritmética destes 4 valores, ou seja, a soma dos valores divido por 4, mas o problema é que, caso uma dessas células estivesse vazia, a fórmula ajustasse automaticamente para fazer a divisão por 3 e não por 4... Caso haja somente 2 valores, fazer a divisão por 2... Existe a possibilidade de fazer isso? Se sim, é possível ser feito com fórmula ou com vba?

Abraço!
Maurício

Ver mais 

2 respostas

Mazzaropi 1834 Posts segunda 16 de agosto de 2010Data de inscriçãoContribuinteStatus 30 de maio de 2018 Última visita - 18 mai 2016 às 11:28
0
Obrigado
Maurício, Bom dia.

A FUNÇÃO MÉDIA do Excel faz exatamente isto o que você precisa.

Suponha que os seus dados estão de A1 até D1 (4 células)

Faça: E1 --> =MÉDIA(A1:D1)

Preencha quantas células desejar.
O resultado será sempre a SOMA das células preenchidas dividido pela QUANTIDADE de células preenchidas.

Era isso o que você queria?
Eu espero ter ajudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
spectre1999 2 Posts quarta 18 de maio de 2016Data de inscrição 18 de maio de 2016 Última visita - 18 mai 2016 às 11:48
É isso mesmo. Muito obrigado.
Ajudou muito!

Abraço!
Maurício