Cálculo de Média Aritmética no Excel

Resolvido/Fechado
spectre1999 Posts 2 Data de inscrição quarta 18 de maio de 2016 Status Membro Última visita 18 de maio de 2016 - 18 mai 2016 às 11:18
spectre1999 Posts 2 Data de inscrição quarta 18 de maio de 2016 Status Membro Última visita 18 de maio de 2016 - 18 mai 2016 às 11:48
Bom dia,

A dúvida que tenho é a seguinte:

Tenho 4 células nas quais são entrados os valores e a quinta célula daria-me a média aritmética destes 4 valores, ou seja, a soma dos valores divido por 4, mas o problema é que, caso uma dessas células estivesse vazia, a fórmula ajustasse automaticamente para fazer a divisão por 3 e não por 4... Caso haja somente 2 valores, fazer a divisão por 2... Existe a possibilidade de fazer isso? Se sim, é possível ser feito com fórmula ou com vba?

Abraço!
Maurício

1 resposta

Mazzaropi Posts 1978 Data de inscrição segunda 16 de agosto de 2010 Status Contribuinte Última visita 18 de novembro de 2022 583
18 mai 2016 às 11:28
Maurício, Bom dia.

A FUNÇÃO MÉDIA do Excel faz exatamente isto o que você precisa.

Suponha que os seus dados estão de A1 até D1 (4 células)

Faça: E1 --> =MÉDIA(A1:D1)

Preencha quantas células desejar.
O resultado será sempre a SOMA das células preenchidas dividido pela QUANTIDADE de células preenchidas.

Era isso o que você queria?
Eu espero ter ajudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
0
spectre1999 Posts 2 Data de inscrição quarta 18 de maio de 2016 Status Membro Última visita 18 de maio de 2016
18 mai 2016 às 11:48
É isso mesmo. Muito obrigado.
Ajudou muito!

Abraço!
Maurício
0

Assine nossa newsletter!

Assine nossa newsletter!