Dúvida Excel - Fórmula SE Contendo Texto e Cálculo [Resolvido]

Posts
7
Data de inscrição
sexta 2 de fevereiro de 2018
Última visita
28 de março de 2018
-
Olá pessoal, estou tendo um grande problema em uma fórmula de Excel, segue abaixo o link para verificarem a planilha:

https://www.sendspace.com/file/lyr5uu

Percebi que o erro ocorre porque a fórmula utiliza as colunas "G" e "H" que contém texto, se na coluna "I" tivesse como alterar a fórmula ou fazer que o excel identifique que se aparecer a palavra "EXCLUÍDA" é igual a "0" zero daria certo, pois quando coloco algum valor nas colunas "G" e "H" a fórmula funciona.

Fórmulas utilizadas:
Coluna G:
=SE(OU(E3="NÃO";C3=0);"EXCLUÍDA";300)

Coluna H:
=SE(G3="EXCLUÍDA";"EXCLUÍDA";G3*C3)

Coluna I:
=SE(D3="ARROZ";(SE(B3<=2;H3*(0,375/100*F3);SE(B3>2;H3*(0,3475/100*F3)))))
+SE(D3="FEIJAO";(SE(B3<=2;H3*(0,375/100*F3);SE(B3>2;H3*(0,3475/100*F3)))))
+SE(D3="PEIXE";(H3*(0,44/100*F3)))
+SE(D3="CARNE";(H3*(0,44/100*F3)))
+SE(D3="FRANGO";(H3*(0,44/100*F3)))
+SE(D3="LATICINIOS";(H3*(0,44/100*F3)))
+SE(D3="ENLATADOS";(H3*(1,25/100*F3)))
+SE(D3="DEMAIS PRODUTOS";(H3*(1,25/100*F3)))

Alguém pode me ajudar por favor?

Agradeço desde já.
Ver mais 

2 respostas

Melhor resposta
Posts
1834
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
30 de maio de 2018
1
Obrigado
David_Benner, Boa noite.

Caso você se interesse em ver como seria utilizando a função PROCV, fiz uma pequena alteração no seu exemplo.

https://www.sendspace.com/file/6ruibs

Faça os seus testes e nos diga se está funcionando como você deseja.

A sua fórmula original seria resumida para essa outra:

=IF(E3="NÃO";0;H3 * VLOOKUP(D3;K3:M10;(IF(OR(D3="ARROZ";D3="FEIJAO");IF(B3<=2;2;3);2));0) * F3)

Observe a vantagem de poder acompanhar os parâmetros na tabela e não ter que editar as fórmulas caso algum se altere.

Espero ter ajudado.
--
Belo Horizonte, MG - Brasil.
Marcílio Lobão

Diga "Obrigado" 1

Algumas palavras de agradecimento nunca são demais. Adicionar comentário

CCM ajudou 8186 usuários este mês

Comentar a resposta do Mazzaropi
Posts
1834
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
30 de maio de 2018
0
Obrigado
David_Benner, Boa tarde.

Tente utilizar a fórmula da coluna I dessa jeito:

Coluna I:
=SE( E3="NÃO";0; SE(D3="ARROZ";(SE(B3<=2;H3*(0,375/100*F3);SE(B3>2;H3*(0,3475/100*F3)))))
+SE(D3="FEIJAO";(SE(B3<=2;H3*(0,375/100*F3);SE(B3>2;H3*(0,3475/100*F3)))))
+SE(D3="PEIXE";(H3*(0,44/100*F3)))
+SE(D3="CARNE";(H3*(0,44/100*F3)))
+SE(D3="FRANGO";(H3*(0,44/100*F3)))
+SE(D3="LATICINIOS";(H3*(0,44/100*F3)))
+SE(D3="ENLATADOS";(H3*(1,25/100*F3)))
+SE(D3="DEMAIS PRODUTOS";(H3*(1,25/100*F3))) )

Por favor, no diga se agora está funcionando como você deseja.

Uma dúvida:
Você está utilizando esse cálculo através da função SE porque precisa se com SE ou porque você ainda não tentou de outra maneira mais eficiente?

Utilizando os seus próprios dados e aumentando a sua tabela de produtos apenas um pouquinho, será possível utilizar a função PROCV com mais eficiência e os dados não precisarão ficar dentro da fórmula. Será tudo dinâmico.
Muito mais fácil de dar manutenção quando precisar.

Tenha um bom dia!
--
Belo Horizonte, MG - Brasil.
Marcílio Lobão
David_Benner
Posts
7
Data de inscrição
sexta 2 de fevereiro de 2018
Última visita
28 de março de 2018
-
Muito Obrigado Marcílio, funcionou, eu até consegui adaptar o que você mandou, eu coloquei assim na primeira linha:

=SE(H3="EXCLUÍDA";0; SE(D3="ARROZ";(SE(B3<=2;H3*(0,375/100*F3);SE(B3>2;H3*(0,3475/100*F3)))))

Não sabia que era só informar a primeira vez que era pra trocar a palavra por 0, pras demais fórmulas que envolvam essa mesma célula multiplicarem por 0 em vez da palavra, muito obrigado!!

E sobre sua dúvida eu estou utilizando com SE pois não consegui uma outra maneira mais eficiente, obrigado pela dica!!
Comentar a resposta do Mazzaropi