Dúvida Excel - Fórmula SE Contendo Texto e Cálculo

Resolvido/Fechado
David_Benner Posts 7 Data de inscrição sexta 2 de fevereiro de 2018 Status Membro Última visita 28 de março de 2018 - Atualizado em 2 fev 2018 às 14:40
Mazzaropi Posts 1978 Data de inscrição segunda 16 de agosto de 2010 Status Contribuinte Última visita 18 de novembro de 2022 - 2 fev 2018 às 20:03
Olá pessoal, estou tendo um grande problema em uma fórmula de Excel, segue abaixo o link para verificarem a planilha:

https://www.sendspace.com/file/lyr5uu

Percebi que o erro ocorre porque a fórmula utiliza as colunas "G" e "H" que contém texto, se na coluna "I" tivesse como alterar a fórmula ou fazer que o excel identifique que se aparecer a palavra "EXCLUÍDA" é igual a "0" zero daria certo, pois quando coloco algum valor nas colunas "G" e "H" a fórmula funciona.

Fórmulas utilizadas:
Coluna G:
=SE(OU(E3="NÃO";C3=0);"EXCLUÍDA";300)

Coluna H:
=SE(G3="EXCLUÍDA";"EXCLUÍDA";G3*C3)

Coluna I:
=SE(D3="ARROZ";(SE(B3<=2;H3*(0,375/100*F3);SE(B3>2;H3*(0,3475/100*F3)))))
+SE(D3="FEIJAO";(SE(B3<=2;H3*(0,375/100*F3);SE(B3>2;H3*(0,3475/100*F3)))))
+SE(D3="PEIXE";(H3*(0,44/100*F3)))
+SE(D3="CARNE";(H3*(0,44/100*F3)))
+SE(D3="FRANGO";(H3*(0,44/100*F3)))
+SE(D3="LATICINIOS";(H3*(0,44/100*F3)))
+SE(D3="ENLATADOS";(H3*(1,25/100*F3)))
+SE(D3="DEMAIS PRODUTOS";(H3*(1,25/100*F3)))

Alguém pode me ajudar por favor?

Agradeço desde já.

2 respostas

Mazzaropi Posts 1978 Data de inscrição segunda 16 de agosto de 2010 Status Contribuinte Última visita 18 de novembro de 2022 583
2 fev 2018 às 20:03
David_Benner, Boa noite.

Caso você se interesse em ver como seria utilizando a função PROCV, fiz uma pequena alteração no seu exemplo.

https://www.sendspace.com/file/6ruibs

Faça os seus testes e nos diga se está funcionando como você deseja.

A sua fórmula original seria resumida para essa outra:

=IF(E3="NÃO";0;H3 * VLOOKUP(D3;K3:M10;(IF(OR(D3="ARROZ";D3="FEIJAO");IF(B3<=2;2;3);2));0) * F3)

Observe a vantagem de poder acompanhar os parâmetros na tabela e não ter que editar as fórmulas caso algum se altere.

Espero ter ajudado.
--
Belo Horizonte, MG - Brasil.
Marcílio Lobão
1

Assine nossa newsletter!

Assine nossa newsletter!