Formula de condição SE no excel 2007 [Resolvido/Fechado]

pieiro 24 Posts quarta 1 de maio de 2013Data de inscrição 11 de novembro de 2016 Última visita - 1 mai 2013 às 10:49 - Última resposta:  mellitus 1
- 22 nov 2015 às 15:49
Boa tarde,

eu queria fazer uma formula no excel com a função SE, mas não estou conseguindo o que quero...
Então é o seguinte: na célula C18 tenho esta formula =SE(C15<=1;"0";SE(C15<=10;"1";SE(C15>10;"2")))
está bem e funciona perfeitamente, mas agora quero usar o valor que resulta dessa formula (0,1 ou 2), numa outra formula, por exemplo: se o valor resultante desta formula for 0 eu quero que apareça noutra célula o valor de uma outra célula subtraído de 2, ex: quero que apareça A12-2, mas A12 é calculado por outra formula não é constante nem é introduzido manualmente é um resultado que depende de outras células/condições.
Resumindo o que eu quero é se C18=0 então faz A12-2, se C18=1 então faz A12-1, se C18=2 então faz A12.

espero não ter ficado confusa esta pergunta...
toda a ajuda é bem vinda, Obrigado

pieiro
Ver mais 

10 respostas

Melhor resposta
Mazzaropi 1834 Posts segunda 16 de agosto de 2010Data de inscriçãoContribuinteStatus 30 de maio de 2018 Última visita - 2 mai 2013 às 10:01
21
Obrigado
Pieiro, Bom Dia.

Bem...realmente ficou um pouco confuso mas vamos lá.

"...na célula C18 tenho esta formula =SE(C15<=1;"0";SE(C15<=10;"1";SE(C15>10;"2"))) está bem e funciona perfeitamente..."

Inicialmente eu estou surpreso que a sua fórmula esteja funcionando já que você está usando ASPAS no valor resultante, transformando-o em TEXTO e não em NÚMERO.
Desta maneira é IMPOSSÍVEL fazer qualquer cálculo matemático com o resultado.

Sugiro usar a fórmula assim:
C18 --> =SE(C15<=1;0;SE(C15<=10;1;SE(C15>10;2)))

Quanto à sua nova fórmula vamos supor que você queira colocá-la na célula D18.
Faça então: D18 --> =SE(C18=0;A12-2;SE(C18=1;A12-1;A12))

ATENÇÃO: Como esta fórmula usa o resultado de A12 como operador, o conteúdo de A12 tem que ser NÚMERO. Verifique se na fórmula de A12 os resultados estão dentro do esperado.

Era isto que você queria?

Espero ter ajudado.

Att. Marcílio Lobão

---
Belo Horizonte, Brasil.
Marcílio Lobão

Obrigado, Mazzaropi 21

CCM ajudou 7082 internautas este mês

Boa tarde, vc pode me ajudar com uma fórmula?
Olá Marcílio, você pode me ajudar com a fórmula abaixo:

Na célula A1 será digitado um valor e na célula A2 preciso de um cálculo, sendo:
Se(A1<=59999;A1*0;SE(A1>=60000<79999;A1*0,1;SE(A1>=80000<99999;A1*0,2;SE(A1>=100000;A1*0,3)))
Mazzaropi 1834 Posts segunda 16 de agosto de 2010Data de inscriçãoContribuinteStatus 30 de maio de 2018 Última visita - 3 set 2014 às 08:56
Luiz, Bom dia.

Quando tiver uma dúvida, ABRA um novo tópico.
Usar tópicos antigos e já resolvidos dificulta para receber ajuda e na procura por dúvidas no site.

Quanto a sua dúvida tenho duas opções para você:

a) Função SE (como solicitado)

A2 --> =SE(A1>=100000;A1 * 0,3; SE(A1>=80000;A1 * 0,2; SE(A1>=60000;A1 * 0,1;0)))

b) Função PROCV (minha sugestão)

Veja o exemplo que fiz para você:
http://speedy.sh/gY9hV/03-09-2014-Exemplo-Funcao-SE-OK.xlsx

Com esta função o processo fica mais organizado na sua planilha, é muito mais fácil de fazer alterações nos valores e nas faixas sem ter que mexer na fórmula.

Era isso o que você queria?
Eu espero ter ajudado.
---------------------------------------
Belo Horizonte, MG - Brasil
Marcílio Lobão
Olá, eu não sabia como criar novo comentário, é a primeira vez que utilizo. Blz, Usei a função SE. Muito Obrigado. Luiz
Luiz Henrique - 20 jan 2015 às 14:10
Olá. Gostaria de tirar uma dúvida.
Preciso elaborar uma fórmula, que ao colocar uma informação em uma célula, ela retorne com a descrição desta informação em outra célula.

Exemplo:

Motivo Chamado Centro de Custo
Financeiro 10.01
pieiro 24 Posts quarta 1 de maio de 2013Data de inscrição 11 de novembro de 2016 Última visita - 2 mai 2013 às 14:05
0
Obrigado
Obrigado pela ajuda, eu já tinha detectado o erro e era esse mesmo, os valores na formula =SE(C15<=1;"0";SE(C15<=10;"1";SE(C15>10;"2"))) estavam entre aspas e por isso não fazia o calculo, depois de retirar as aspas ficou bom, a formula que estava usando para o calculo seguinte é exactamente igual a sua sugestão :) muito obrigado na mesma, acho que ainda vou precisar de mais algumas dicas no excel, depois posto as questões no forum.
mais uma vez obrigado.

abraço
Boa tarde

eu estou com dificuldades em transformar em formula o seguinte calculo

a-b*c=d sendo que o resultado de D depende tambem do resultado de e*f, apos a multiplicaçao de e*f obtem-se o resultado de D com a soma ou subtraçao do resultado de a-b*c e a multiplicaçao de e*f

alguem me ajuda?