Dúvida Excel - FUNÇÃO SE COM PROCV EM PLANILHAS [Resolvido/Fechado]

Denunciar
Posts
7
Data de inscrição
sexta 2 de fevereiro de 2018
Status
Membro
Última visita
28 de março de 2018
-
Mazzaropi
Posts
1833
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
30 de maio de 2018
-
Olá, uso atualmente a fórmula PROCV em um banco de dados onde jogo um nome e ele puxa da mesma planilha só que aba diferente as informações, muito útil, atualmente a fórmula está assim:

Planilha_1, na ABA_1
=PROCV(C2;‘ABA_1’!A2:AD50;2;0)

Onde nesta situação ele vai me mostrar o que está na segunda coluna, até aí tudo bem, agora eu gostaria de fazer a seguinte coisa, só que não estou conseguindo:

Pesquisar em Planilha_1 na ABA_1, se não tiver essa informação procurar em Planilha_2 na ABA_1, se não tiver essa informação procurar em Planilha_3 na ABA_1, se não tiver essa informação informar “INEXISTENTE”.

Alguém saberia me dar uma força nessa fórmula?? Agradeço desde já!!

2 respostas

Posts
1833
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
30 de maio de 2018
484
David_Benner, Boa noite.

A fórmula do jeito que você precisa é essa:
=SEERRO(PROCV(C2;'[Planilha_1.xlsx]ABA_1'!A2:AD50;2;0);SEERRO(PROCV(C2;'[Planilha_2.xlsx]ABA_1'!A2:AD50;2;0);SEERRO(PROCV(C2;'[Planilha_3.xlsx]ABA_1'!A2:AD50;2;0);"INEXISTENTE")))

Para firmar o link na primeira vez abra as tres planilhas e com elas abertas aplique a fórmula.
Salve primeiro a planilha onde está a fórmula.
Pode fechar as outras.

Você pode utilizar a planilha de pesquisa sem ter que abrir as outras todas as vezes.
Porém ao abrir a planilha, ela emitirá um aviso que existem links relacionados a essa planilha e você deve ACEITAR para a pesquisa poder funcionar sem ter que abrir as outras planilhas.

Faça um teste e nos diga se funcionou como você precisava.

Eu espero ter ajudado.
--
Belo Horizonte, MG - Brasil.
Marcílio Lobão
David_Benner
Posts
7
Data de inscrição
sexta 2 de fevereiro de 2018
Status
Membro
Última visita
28 de março de 2018

Marcílio, muitíssimo obrigado, funcionou perfeitamente!!
Obrigado pelas dicas!!
Posts
1833
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
30 de maio de 2018
484
David_Benner, Boa noite.

Fico feliz em ter ajudado você.

Obrigado pelo feedback.

Tenha um ótimo fim de semana!
--
Belo Horizonte, MG - Brasil.
Marcílio Lobão