Dúvida Excel - FUNÇÃO SE COM PROCV EM PLANILHAS [Resolvido]

David_Benner 7 Posts sexta 2 de fevereiro de 2018Data de inscrição 28 de março de 2018 Última visita - 1 mar 2018 às 17:23 - Última resposta: Mazzaropi 1834 Posts segunda 16 de agosto de 2010Data de inscriçãoContribuinteStatus 30 de maio de 2018 Última visita
- 2 mar 2018 às 17:20
Olá, uso atualmente a fórmula PROCV em um banco de dados onde jogo um nome e ele puxa da mesma planilha só que aba diferente as informações, muito útil, atualmente a fórmula está assim:

Planilha_1, na ABA_1
=PROCV(C2;‘ABA_1’!A2:AD50;2;0)

Onde nesta situação ele vai me mostrar o que está na segunda coluna, até aí tudo bem, agora eu gostaria de fazer a seguinte coisa, só que não estou conseguindo:

Pesquisar em Planilha_1 na ABA_1, se não tiver essa informação procurar em Planilha_2 na ABA_1, se não tiver essa informação procurar em Planilha_3 na ABA_1, se não tiver essa informação informar “INEXISTENTE”.

Alguém saberia me dar uma força nessa fórmula?? Agradeço desde já!!
Ver mais 

3 respostas

Melhor resposta
Mazzaropi 1834 Posts segunda 16 de agosto de 2010Data de inscriçãoContribuinteStatus 30 de maio de 2018 Última visita - 1 mar 2018 às 18:08
1
Obrigado
David_Benner, Boa noite.

A fórmula do jeito que você precisa é essa:
=SEERRO(PROCV(C2;'[Planilha_1.xlsx]ABA_1'!A2:AD50;2;0);SEERRO(PROCV(C2;'[Planilha_2.xlsx]ABA_1'!A2:AD50;2;0);SEERRO(PROCV(C2;'[Planilha_3.xlsx]ABA_1'!A2:AD50;2;0);"INEXISTENTE")))

Para firmar o link na primeira vez abra as tres planilhas e com elas abertas aplique a fórmula.
Salve primeiro a planilha onde está a fórmula.
Pode fechar as outras.

Você pode utilizar a planilha de pesquisa sem ter que abrir as outras todas as vezes.
Porém ao abrir a planilha, ela emitirá um aviso que existem links relacionados a essa planilha e você deve ACEITAR para a pesquisa poder funcionar sem ter que abrir as outras planilhas.

Faça um teste e nos diga se funcionou como você precisava.

Eu espero ter ajudado.
--
Belo Horizonte, MG - Brasil.
Marcílio Lobão

Obrigado, Mazzaropi 1

Algo a dizer? Adicionar comentário

CCM ajudou 11634 usuários este mês

David_Benner 7 Posts sexta 2 de fevereiro de 2018Data de inscrição 28 de março de 2018 Última visita - 2 mar 2018 às 17:01
Marcílio, muitíssimo obrigado, funcionou perfeitamente!!
Obrigado pelas dicas!!
Comentar a resposta do Mazzaropi
Mazzaropi 1834 Posts segunda 16 de agosto de 2010Data de inscriçãoContribuinteStatus 30 de maio de 2018 Última visita - 2 mar 2018 às 17:20
0
Obrigado
David_Benner, Boa noite.

Fico feliz em ter ajudado você.

Obrigado pelo feedback.

Tenha um ótimo fim de semana!
--
Belo Horizonte, MG - Brasil.
Marcílio Lobão
Comentar a resposta do Mazzaropi