Preciso juntar 2 tabelas e somar valores caso tenha mesmo campo em comum [Resolvido]

Denunciar
Posts
1
Data de inscrição
sexta 10 de janeiro de 2020
Status
Membro
Última visita
10 de janeiro de 2020
-
Adalberto27
Posts
37
Data de inscrição
domingo 9 de junho de 2019
Status
Contribuinte
Última visita
terça 4 de fevereiro de 2020
-
Bom dia,

Preciso juntar 2 planilhas em 1, a estrutura é assim:

DIA | METROS | KGS

As 2 planilhas são iguais, porém preenchidas separadamente, portanto pode ficar assim:

Plan1
01/12/2019 | 10 | 5
02/12/2019 | 20 | 8
04/12/2019 | 15 | 10

Plan2
01/12/2019 | 30 | 11
02/12/2019 | 50 | 20
06/12/2019 | 80 | 30

Quero que fique assim:
Plan3
01/12/2019 | 40 | 16
02/12/2019 | 70 | 28
04/12/2019 | 15 | 10
06/12/2019 | 80 | 30

Existe essa possibilidade ?
Configuração: Windows / Chrome 79.0.3945.117

1 resposta

Posts
37
Data de inscrição
domingo 9 de junho de 2019
Status
Contribuinte
Última visita
terça 4 de fevereiro de 2020
15
Boa noite

Sim da para fazer utilizando a função SOMASE.

Na célula B1 da Plan3 copie e cole a fórmula abaixo e arraste para as demais células da coluna B:
=SOMASE(Plan1!$A$1:$A$100;$A1;Plan1!$B$1:$B$100)+SOMASE(Plan2!$A$1:$A$100;$A1;Plan2!$B$1:$B$100)
Na célula C1 da Plan3 copie e cole a fórmula abaixo e arraste para as demais células da coluna C:
=SOMASE(Plan1!$A$1:$A$100;$A1;Plan1!$C$1:$C$100)+SOMASE(Plan2!$A$1:$A$100;$A1;Plan2!$C$1:$C$100)
Um abraço