5
Obrigado

Algumas palavras de agradecimento nunca são demais.

Excel: funções lógicas SE, E, OU, NÃO

Nessa dica, vamos tratar das funções SE, E, OU e NÃO, algumas das mais utilizadas fórmulas do Excel. Com exemplos práticos e diagramas, você conseguirá visualizar facilmente como usar cada uma dessas funções e saberá qual delas aplicar em cada contexto.




Função SE

Função SE isolada

Se o valor em A1 for superior ou igual a 19, então exibir 20. Se o valor for 18 ou menor, exibir o valor inserido em A1. Para isso, usamos a fórmula: =SE(A1>=19;20;A1)



Saiba mais sobre a função SE aqui.

Função SE composta

Se o valor em A1 for inferior a 4, exibir Nulo; se estiver entre 4 e 8, exibir Médio; se estiver entre 8 e 12, exibir Médio; se estiver entre 12 e 16, exibir Bom; para valores maiores que 16, exibir Muito bom. A fórmula para criar essa estrutura é: =SE(A1<4;"Nulo";SE(A1<8;"Regular";SE(A1<12;"Médio";SE(A1<16;"Bom";"Muito bom")))).


Saiba mais sobre a função SE composta aqui.

Função E

Exibir o valor Senhora condessa! se todas essas condições se realizarem: A2 (sexo)=mulher, B2 (estado civil)=casada, C2 (esposa)=conde e D2 (chamada)=presente. Caso contrário, exibir Bom dia. Para essa construção, a fórmula é: =SE(E(A2="mulher";B2="casada"; C2="conde"; D2="presente"); "Senhora condessa!"; "Bom dia").

Função OU

Exibir Piloto se A3 contiver um dos seguintes dados: avião, fórmula 1, moto. Por outro lado, exibir Motorista se A3 contiver carro ou obras. Se A3 não contiver nenhum dos dados acima, exibir ?. A fórmula será:
=SE(OU(A3="avião";A3="fórmula 1"; A3="moto");"Piloto"; SE(OU(A3="carro";A3="obras");"Motorista";"?")).

Função NÃO

A fórmula =SE(ENT(A3)=A3;"inteiro";"decimal") dode ser escrita de outras maneiras utilizando a função NÃO. Por exemplo:


=SE(NÃO(ENT(A3)=A3);"decimal";"inteiro")

=SE(A4<>"francês";"estrangeiro";"europeu")

=SE(NÃO(A4="francês");"estrangeiro";"europeu")

Combinações

As funções E, OU, NÃO são, frequentemente, associados à função SE. O interesse para aquele que utiliza uma planilha é definir uma tabela de verdade e desenhar um organograma representando o algoritmo do problema a ser resolvido, combinando as quatro funções e garantindo o respeito entre os parênteses e os ponto e vírgulas para que a fórmula funcione. Essa fórmula deve ser testada sistematicamente, tentando todos as possibilidades e os valores limite das variáveis.

Foto: © Excel.

Veja também

Este documento, intitulado 'Excel: funções lógicas SE, E, OU, NÃO', está disponível sob a licença Creative Commons. Você pode copiar e/ou modificar o conteúdo desta página com base nas condições estipuladas pela licença. Não se esqueça de creditar o CCM (br.ccm.net) ao utilizar este artigo.