Excel - fórmulas

[Resolvido/Fechado]
Denunciar
Posts
4
Data de inscrição
quinta 13 de outubro de 2016
Status
Membro
Última visita
terça 1 de novembro de 2016
-
Posts
1943
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
22 de setembro de 2021
-
Caros amigos,

Tenho tentado há algum tempo mas sem sucesso, pois não sou um conhecedor muito profundo de excel.

Vamos lá, preciso desenvolver uma fórmula que me dê o seguinte resultado:

de 0 até 800 km = 0 dias
de 801 até 1600 km = 1 dias
de 1601 até 2400 km = 2 dias

Para explicar: Meu carro roda até no máximo 800 km/dia, ou 10 horas.
Então até os 800 km eu preciso de um dia para rodar e assim por diante.
Este valor servirá para calcular o quanto terei de hospedagem para o motorista.

Desde já agradeço.

3 respostas

Posts
1943
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
22 de setembro de 2021
564
marceloguimaraes.sp, Bom dia.

Como você não explicou como é o layout da sua planilha fica mais difícil de ajudá-lo de forma conclusiva.

No Excel é possível fazer os cálculos de várias maneiras.
A fórmula abaixo permite você calcular os dias de forma contínua além da sua tabela, isto é, qualquer kilometragem.

Suponha:
A1 --> Qtde Kilometros

C1 --> Dias --> Fórmula
=SE(A1<=0;0;SE(MOD(A1;800)=0;INT(A1/800)-1;INT(A1/800)))

Era isso o que você queria?
Eu espero ter ajudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
Posts
4
Data de inscrição
quinta 13 de outubro de 2016
Status
Membro
Última visita
terça 1 de novembro de 2016

Desculpe Marcílio.
Vou tentar explicar melhor:

Tenho um motorista que pode rodar por dia 800 km no máximo.

Acima disto ele terá que pernoitar.

Então penso em criar uma tabela da seguinte forma:

De 0 até 800 km = 0 pernoite + 0 refeição extra
De 801 até 1600 km = 1 pernoite + 1 refeição extra
De 1601 até 2400 km = 2 pernoite + 2 refeições extras

Estes valores se relacionam diretamente com o custo final de minha viagem.

Desta forma:

Uma viagem de 800 km não me adiciona nada em meu orçamento, porém uma de 1600 me adicionaria 1 pernoite e 1 refeição a mais, impactando diretamente no meu lucro.
Posts
4
Data de inscrição
quinta 13 de outubro de 2016
Status
Membro
Última visita
terça 1 de novembro de 2016

Exatamente isto que me enviou Mazzaropi, muito obrigado pela ajuda.
Posts
1943
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
22 de setembro de 2021
564
marceloguimaraes.sp,

Obrigado pelo feedback.
Fico feliz em ter ajudado
--
Belo Horizonte, Brasil.
Marcílio Lobão

Assine nossa newsletter!

Receba toda semana o melhor conteúdo

Assine nossa newsletter!