Calcular o aproveitamento escolar trimestral

Fechado
AlbinoMrio - 17 ago 2018 às 01:56
 Perfil bloqueado - 24 ago 2018 às 05:52
Bom dia,

Fórmula para calcular o aproveitamento escolar

1 resposta

Perfil bloqueado
24 ago 2018 às 05:52
Veja esta resposta do Mazzaropi:

https://br.ccm.net/forum/affich-209006-formula-par-calcular-notas-escolares

No seu caso vejo duas possibilidades principais:

1) A sua versão de Excel é em PORTUGUÊS, mas você está digitando as notas com ponto no lugar de vírgula para separar as casas decimais.
A nota seria 8,0 e não 8.0
Se for isto, o que está acontecendo é que o Excel considera o 8.0 como sendo texto.
Logo, sendo todas as quatro células texto não há número para ser dividido.
Então aparece o erro porque não existe divisão por zero na matemática.

SOLUÇÃO:
Se for isto basta digitar os números com vírgula e tudo está resolvido.

2) A sua versão de Excel é em INGLÊS, logo os números aceitam
ponto para separar as casas decimais.
MAS, no intervalo desejado AINDA não existem as notas, logo não há o que se dividir.
Novamente o erro aparece.

SOLUÇÃO:
Se for isto basta incluir na fórmula um tratamento de erro para que até que sejam digitados valores nas notas, a célula fique vazia ao invés de aparecer erro.

Supondo que a Média esteja em B10, faça:

B10 --> =SE(ÉERROS(MÉDIA(B5:B8);"";MÉDIA(B5:B8))
Está resolvido.
0

Assine nossa newsletter!

Assine nossa newsletter!
Junte-se à comunidade