Excel: ativar uma lista de validação de acordo com certos critérios

Faça uma pergunta
É possível desativar ou ativar uma lista de validação com base em certos critérios (valor numérico ou texto em uma célula ou intervalo de células).

Para simplificar ou encurtar fórmulas, sobretudo se os valores-alvo estiverem em uma planilha diferente da planilha com a lista de validação, é aconselhável nomear o intervalo de células que contém esses dados. Por exemplo, esses dados se encontram na planilha chamada Plan2. Colocar o intervalo em questão (Plan2, intervalo A1:A20) sublinhado e nomeá-la (Nome/Definir nome) como Titi, por exemplo.


Antes de criar a lista de validação, é imperativo que a condição critério seja TRUE (Verdadeiro).


Se, por exemplo, a ativação da lista de validação estiver sujeita ao conteúdo de uma célula que no exemplo abaixo é a célula B5, insira um valor X nesta célula.

Na célula D3, queremos criar a lista de validação que exibirá os dados do intervalo chamado Titi. Normalmente, nós teríamos digitado como fórmula de validação
= Titi
. Neste caso, vamos digitar
= SE (B5 <>"";Titi;"")
. Agora é possível testar a lista de validação, mas apenas quando a célula B5 estiver preenchida.


É possível pensar de outra maneira integrando o teste na definição do intervalo chamado, desta vez, de lista, para evitar as interferências com o intervalo chamado ‘Titi’:

=SE(Plan1!$B$5<>"";DESLOC(Plan2!$A$1;1;;COUNTA(Plan2!$A:$A)-1);"")

Com base neste princípio, a acessibilidade de uma lista de validação pode ser submetida a qualquer tipo de controle. Suponhamos que queiramos usar a lista de validação quando a soma dos valores do intervalo A1:A20 for inferior ou igual a 20. Neste caso, a condição TRUE (verdadeiro) é inferior ou igual a 20, incluindo as células vazias que retornarão ao valor zero quando a soma for feita. A fórmula para a criação da lista de validação será:

=SE(SOMA($A$1:$A$20)<=20;Titi;"")

No caso da acessibilidade da lista de validação ser submetida a uma soma mínima tal como 20 ou mais, é obrigatório digitar no intervalo A1 a A20 um valor, pelo menos igual ou superior a 20, ou a soma do intervalo preencherá esta condição. Em seguida, você poderá criar a lista de validação e a fórmula será:

=SE(SOMA($A$1:$A$20)>=20;Titi;"")

A partir deste exemplo é possível imaginar qualquer tipo de condição.

Baixe o arquivo de exemplo (em francês).

Foto: © Microsoft.
Jean-François Pillou

Jean-François Pillou - Fundador do CCM
Mais conhecido como Jeff, Jean-François Pillou é o fundador do CommentCaMarche.net. Ele também é CEO do CCM Benchmark e diretor digital do Grupo Figaro.

Mais informações sobre a equipe do CCM

Veja também