Excel: função PROCV (VLOOKUP)


Para aplicar a função PROCV do Excel, você deve selecionar as suas referências em sua planilha. Neste exemplo, a sua referência será $A$2:$D$10. Depois de selecioná-la, clique em Inserir o Nome > Definir (para este exemplo, dei o nome de CAMPOS).

No Excel 2007, a definição do nome é feita através do menu Fórmulas.

Onde os dados encontrados aparecerão

Neste exemplo, os dados aparecerão:


H1= termo a ser procurado;
H4= descrição encontrada (coluna 2 da nossa planilha);
H6= quantidade encontrada (coluna 3 da nossa planilha);
H8= qreço encontrado (coluna 4 da nossa planilha).

Como aplicar as fórmulas

A sintaxe de base da função
PROCV é
:

=PROCV(valor_pesquisa;tabela_matriz;no_index_lig;valor_aproximado)
e
 (=VLOOKUP(lookup_value,table_array,row_index_num,range_lookup)

H4:
=PROCV($H$1;CAMPOS;2;FALSO) 
. Para ser mais claro, temos que partir do conteúdo da célula H1 e procurar, na primeira linha da tabela CAMPOS, a coluna começando com esse conteúdo e extrair o valor colocado na segunda linha. FALSO, mostra que estamos procurando uma correspondência exata para evitar a mensagem #N/A, se nada foi encontrado, é porque foi utilizada a fórmula seguinte e a palavra Desconhecido aparecerá na célula do resultado:

=SE(FORNA(PROCV($H$1;CAMPOS;2;FALSO));"Desconhecido";PROCV($H$1;CAMPOS;2;FALSO))

Com o Excel 2007 existe uma fórmula mais curta:

=SEERRO(PROCV($H$1;CAMPOS;2;FALSO);"Desconhecido")

H6:
=PROCV($H$1;CAMPOS;3;FALSO)
. Simplificando, parta do conteúdo da célula H1, procure na primeira linha da tabela CAMPOS, a coluna começando com esse conteúdo para poder extrair o valor colocado na terceira linha> FALSO, prova que estamos procurando uma correspondência exata. Para não visualizar a mensagem #N/A, se nada foi encontrado, a fórmula seguinte e a palavra Desconhecido aparecerá na célula do resultado:

=SE(FORNA(PROCV($H$1;CAMPOS;3;FALSO));"Desconhecido";PROCV($H$1;CAMPOS;3;FALSO))

Com o Excel 2007 existe uma fórmula mais curta:

=SEERRO(PROCV($H$1;CAMPOS;3;FALSO);"Desconhecido")

H8:
=PROCV($H$1;CAMPOS;4;FALSO)
. Para fazer mais fácil, é melhor partir sempre do conteúdo da célula H1 e procurar a coluna começando com esse mesmo conteúdo na primeira linha da tabela CAMPOS, depois extrair o valor colocado na quarta linha. FALSO, mostra que estamos procurando uma correspondência exata. Para evitar que a mensagem #N/A, se exiba se nada foi encontrado, utilize a seguinte fórmula para Desconhecido aparecerá na célula do resultado:

=SE(FORNA(PROCV($H$1;CAMPOS;4;FALSO));"Desconhecido";PROCV($H$1;CAMPOS;4;FALSO)
)

Com o Excel 2007 existe uma fórmula mais curta:

=SEERRO(PROCV($H$1;CAMPOS;4;FALSO);"Desconhecido")

Na fórmula, definimos como sendo FALSO se precisamos procurar o valor exato (# N/A se não for encontrado) e VERDADEIRO se o valor for igual ou inferior mais próximo; neste caso, a lista de valores deve estar organizada. Se a configuração for deixada de lado, seu valor padrão será sempre VERDADEIRO.

Foto: © LINE ICONS - Shutterstock.com
Artigo original publicado por aakai1056. Tradução feita por pintuda. Última modificação: 27 de novembro de 2017 às 10:08 por Pedro.CCM.
Este documento, intitulado 'Excel: função PROCV (VLOOKUP)', está disponível sob a licença Creative Commons. Você pode copiar e/ou modificar o conteúdo desta página com base nas condições estipuladas pela licença. Não se esqueça de creditar o CCM (https://br.ccm.net/) ao utilizar este artigo.
Como trabalhar com a função PROCH (HLOOKUP) no Excel
Fórmulas básicas do Excel