1
Obrigado

Algumas palavras de agradecimento nunca são demais.

Excel: como usar a função PROCV e PROCH

A função PROCV é utilizada para localizar dados em tabelas organizadas em linhas. Essa função é similar à função PROCH, que serve para localização de dados em tabelas por coluna. Saiba abaixo como utilizar essas funções.




Sintaxe da função PROCV e PROCH

A sintaxe da função não é das mais simples. Ao todo, você deve inserir três ou quatro informações para que ela tenha condições identificar exatamente o que você está procurando. O modelo de sintaxe é o seguinte:
  • PROCV:

=PROCV("valor_procurado"; matriz_tabela; núm_linha; [intervalo_procurado])
  • PROCH:

=PROCH("valor_procurado"; matriz_tabela; núm_linha; [intervalo_procurado])

Elementos da função PROCV e PROCH

Agora, veremos o que significa cada um dos elementos da função:
  • Valor procurado: o primeiro elemento deve descrever o que deverá ser localizado. Esse elemento pode ser um valor ou texto inserido na célula de referência.
  • Matriz da tabela: aqui, é preciso definir onde a busca será feita. Assim, é preciso inserir a sequência de células que compõem a tabela na qual a função deverá buscar o dado que você precisa.
  • Número da linha: nessa seção, o usuário deve informar o número da linha da tabela em que o valor que ele procura está. Vale destacar que a numeração não diz respeito ao número da célula, mas da tabela. Assim, o valor 1 informará o primeiro valor da tabela, mesmo que ele esteja, por exemplo, na célula C3.
  • Intervalo procurado: esse é o único elemento opcional da sintaxe. Se você inserir VERDADEIRO, a função, caso não encontre uma correspondência exata, informará o valor mais aproximado. Já se inserir FALSO, a função apenas exibirá uma resposta caso encontre uma correspondência exata. Caso o usuário opte por não inserir nada nessa seção, a função considerará como VERDADEIRO.

Exemplo de uso da função PROCV

Para o nosso exemplo, vamos utilizar uma tabela simples, com apenas quatro colunas e três linhas. Nosso modelo é o seguinte:



Agora, você deve escolher qualquer outra célula fora da tabela onde as funções serão inseridas e, consequentemente, os valores encontrados serão apresentados.

Vamos primeiro localizar o primeiro valor associado à linha Carros. Para isso, a sintaxe utilizada será:

=PROCV("Carros"; A1:D3; 2; VERDADEIRO)


Nesse caso, o valor apresentado será 4.

Agora, vamos usar o elemento FALSO para que apenas resultados exatos sejam apresentados em uma busca na coluna Motocicletas:

=PROCV("Motocicletas"; A1:D3; 3; FALSO)


Nesse caso, o valor apresentado será 7.

Por último, vamos omitir o último elemento e fazer uma busca na coluna Caminhões. Lembre-se que, ao fazer isso, o sistema considera que a busca é feita com o elemento VERDADEIRO:

=PROCV("Caminhões"; A1:D3; 4)


Nesse caso, o valor apresentado será 11.

Exemplo de uso da função PROCH

Para o nosso exemplo, vamos utilizar uma tabela simples, com apenas três colunas e quatro linhas. Nosso modelo é o seguinte:



Agora, você deve escolher qualquer outra célula fora da tabela onde as funções serão inseridas e, consequentemente, os valores encontrados serão apresentados.

Vamos primeiro localizar o primeiro valor associado à coluna Carros. Para isso, a sintaxe utilizada será:

=PROCH("Carros"; A1:C4; 2; VERDADEIRO)


Nesse caso, o valor apresentado será 4.

Agora, vamos usar o elemento FALSO para que apenas resultados exatos sejam apresentados em uma busca na coluna Motocicletas:

=PROCH("Motocicletas"; A1:C4; 3; FALSO)


Nesse caso, o valor apresentado será 7.

Por último, vamos omitir o último elemento e fazer uma busca na coluna Caminhões. Lembre-se que, ao fazer isso, o sistema considera que a busca é feita com o elemento VERDADEIRO:

=PROCH("Caminhões"; A1:C4; 4)


Nesse caso, o valor apresentado será 11.

Mensagens de erro da função

Alguns erros na inserção dos elementos na função podem ocasionar mensagens de erro na célula de destino. Veja a causa de alguns deles para que você saiba como reverter o problema:
  • #VALUE!: esse valor surge se você inserir um valor menor que 1 no elemento Número de linha.
  • #REF!: esse valor surge se você inserir um valor maior que o número de linhas da tabela no elemento Número de linha.
  • #N/D: esse valor surge se você inserir FALSO no elemento Intervalo procurado e a função não localizar uma correspondência exata.


Foto: © dennizn - Shutterstock.com

Foto: © LINE ICONS - Shutterstock.com
Este documento, intitulado 'Excel: como usar a função PROCV e PROCH', está disponível sob a licença Creative Commons. Você pode copiar e/ou modificar o conteúdo desta página com base nas condições estipuladas pela licença. Não se esqueça de creditar o CCM (br.ccm.net) ao utilizar este artigo.
1 Comentário

Assine nossa newsletter!

Receba toda semana o melhor conteúdo

Assine nossa newsletter!