Unir Células com valores Iguais

Fechado
Paulo Branquinho - 24 ago 2015 às 11:18
 Paulo - 28 ago 2015 às 13:26
Bom dia,


Tenho um problema.

Preciso desenvolver uma folha excel que agrupe dois valores iguais, e que ao mesmo tempo some dados existentes, nestas repetições.

tenho o seguinte:

39269000 1
41026100 5
87089099 2
39269000 6
41026100 12
87089099 1


A ideia é que seja agrupado da seguinte maneira:

39269000 7
41026100 17
87089099 3


Existe alguma fórmula ou Macro que me ajude nisso?

Qualquer ajuda é altamente agradecida

4 respostas

Mazzaropi
Posts
1963
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
25 de abril de 2022
584
24 ago 2015 às 12:48
Paulo Branquinho, Boa tarde.

Suponha:
COD --> A2:A20
QTE --> B2:B20

FAÇA:

COD
H1 --> =SEERRO(ÍNDICE($A$2:$A$20;CORRESP(0;ÍNDICE(CONT.SE($H$1:H1;$A$2:$A$20););));"")

QTE
I2 --> =SE(H2="";"";SOMASE(A2:A20;H2;B2:B20))

Por favor, nos dia se funcionou para você.
Eu espero ter ajudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
0

Assine nossa newsletter!

Assine nossa newsletter!