Unir Células com valores Iguais [Fechado]

- - Última resposta:  Paulo - 28 ago 2015 às 13:26
Bom dia,


Tenho um problema.

Preciso desenvolver uma folha excel que agrupe dois valores iguais, e que ao mesmo tempo some dados existentes, nestas repetições.

tenho o seguinte:

39269000 1
41026100 5
87089099 2
39269000 6
41026100 12
87089099 1


A ideia é que seja agrupado da seguinte maneira:

39269000 7
41026100 17
87089099 3


Existe alguma fórmula ou Macro que me ajude nisso?

Qualquer ajuda é altamente agradecida
Ver mais 

4 respostas

Posts
1833
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
30 de maio de 2018
461
0
Obrigado
Paulo Branquinho, Boa tarde.

Suponha:
COD --> A2:A20
QTE --> B2:B20

FAÇA:

COD
H1 --> =SEERRO(ÍNDICE($A$2:$A$20;CORRESP(0;ÍNDICE(CONT.SE($H$1:H1;$A$2:$A$20););));"")

QTE
I2 --> =SE(H2="";"";SOMASE(A2:A20;H2;B2:B20))

Por favor, nos dia se funcionou para você.
Eu espero ter ajudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão
0
Obrigado
Marcilio,

Obrigado pela ajuda, mas ao inserir a formula:

=SE.ERRO(ÍNDICE($A$2:$A$20;CORRESP(0;ÍNDICE(CONTAR.SE($H$1:H1;$A$2:$A$20););));"") - O RETORNO QUE TENHO É VALOR ZERO

=SE(H2="";"";SOMASE(A2:A20;H2;B2:B20)) - O RETORNO QUE TENHO É VALOR ZERO

Se me conseguir ajudar na execução desta formula agradeço.

MEu office é 2013.

nota que inseri códigos A2:A20 e qte B2:B20
0
Obrigado
Marcilio,

Na planilha que enviou, que agradeço, pretendo adicionar + 2 colunas com valor(euros/usd) e peso (Kg), que queria que se refletissem nas colunas seguintes:

Este é a quadro inicial

COD QTE Valor Peso
39269000 1 10 50
41026100 5 30 20
87089099 2 5 1
39269000 6 12 5
41026100 12 5 30
87089099 1 20 5
39269000 5 4 86

Isto é o que pretendo:

COD QTE Valor Peso
39269000 12 26 141
41026100 17 35 50
87089099 3 25 6

Saliento que para COD e QTE, você já me ajudou:).. que mais uma vez agradeço.

Agora queria apenas fazer refletir o mesmo para Valor e Peso:)

Tentei copiar a fórmula SE, mas não funcionou, pode me ajudar?

Obrigado
Posts
1833
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
30 de maio de 2018
461
0
Obrigado
Paulo Branquinho,

Baixei a sua planilha.

Inicialmente devo lhe dizer que a sua planilha está com um problema sério.
Vários campos numéricos estão com formato TEXTO.
Isso vai lhe causar inúmeros problemas e dependendo da evolução da planilha torná-la inoperante.
Sugiro FORTEMENTE você converter os números que estão em formato texto em formato numérico.

Mas, caso queira continuar do jeito que está, a única saída para atender a sua nova demanda é usar esta fórmula abaixo na célula B6:

B6 -->
=SE(DU_Simplificado!J3>0;TEXTO(DU_Simplificado!J3;"#######0");"")


Eu espero ter ajudado.
Ainda no seguimento desta planilha, que ainda está em desenvolvimento, mas agora bem melhor, com suas ajudas, diga me por favor, existe alguma forma de no quadro em baixo, fazer com que automaticamente assuma por ordem crescente(sendo que o principal é o COD, mas os restantes dados tem que acompanhar).

COD QTE Valor Peso
39269000 12 26 141
41026100 17 35 50
87089099 3 25 6