Formula para unir células iguais e somar as colunas ao lado [Fechado]

- - Última resposta:  Michael - 5 set 2019 às 12:01
Boa Noite,

Preciso muito de um formula que olhe para a coluna COD_ITEM, se for igual, soma os dados das colunas do lado, em uma em uma única linha, por exemplo:

COD_ ITEM DES_ITEM QTD_LANCAMENTO VLR TOTAL
37 hydrea 500mg c/ 100 capsulas 1,0000 244,44
37 hydrea 500mg c/ 100 capsulas 1,0000 244,44
37 hydrea 500mg c/ 100 capsulas 1,0000 244,44
40 halo decanoato 50mg/ml 1ml c/ 15amp 15,0000 144,00

E fique assim:


COD_ITEM DES_ITEM QTD_LANCAMENTO VLR TOTAL
37 hydrea 500mg c/ 100 capsulas 3,0000 733,32
40 halo decanoato 50mg/ml 1ml c/ 15amp 15,0000 144,00


Obrigada! É bem urgente para um trabalho de MBA.
Ver mais 

1 resposta

Melhor resposta
Posts
1833
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
30 de maio de 2018
471
18
Obrigado
Médully, Boa noite.

Considerando:
Coluna A --> COD_ ITEM
Coluna B --> DES_ITEM
Coluna C --> QTD_LANCAMENTO
Coluna D --> VLR TOTAL

Dados iniciando em A2.

Faça:

F2 -->
=SEERRO(ÍNDICE($A$2:$A$20;CORRESP(0;ÍNDICE(CONT.SE($F$1:F1;$A$2:$A$20););));"")

G2 -->
=SE(F2="";"";SOMASE($A$2:$A$20;F2;$C$2:$C$20))

H2 -->
=SE(F2="";"";SOMASE($A$2:$A$20;F2;$D$2:$D$20))

Adapte os intervalos à sua realidade.
Cuidado com sinais $ nas fórmulas.
O lugar deles é fundamental para o funcionamento da mesma.

Depois de montar a primeira linha é só arrastar as fórmulas paras as linhas de baixo.

Era isso o que você queria?
Eu espero ter ajudado.
--
Belo Horizonte, Brasil.
Marcílio Lobão

Diga "Obrigado" 18

Estamos felizes de ter ajudado! Ajudamos você? Então, deixe um comentário sobre nós! Avalie o CCM

CCM 21968 internautas nos agradeceram este mês