Excel vba formulas como output em celulas

- - Última resposta: Adalberto27
Posts
23
Data de inscrição
domingo 9 de junho de 2019
Status
Contribuinte
Última visita
27 de setembro de 2019
- 27 jun 2019 às 21:10
Bom dia,
Olá estou fazendo um programa em VBA que preciso escrever equações em planilha de Excel onde a quantidade de celulas utilizadas na função varia de acordo com o numero de dados.
por exemplo: preciso escrever uma planilha a função SOMA() cujo intervalo é de G2:Gn, em que "n'' é variavel.
no programa eu encontro o valor de "n". depos preciso inserir esse valor para escrever numa célula:
tipo:
sheets("planilha1").Range("A2")="=SUM(G2:Gn)
Em caso n=5, vai por na célula A2
=SOMA(G2:G5)

Mas nao sei como faço "n" ser lido na formula em VBA como 5.

Tente diversas formas mas ainda nao sei. Algeum me ajuda?
Ver mais 

1 resposta

Posts
23
Data de inscrição
domingo 9 de junho de 2019
Status
Contribuinte
Última visita
27 de setembro de 2019
10
0
Obrigado
Boa noite

Experimente assim:

Sub InsereFórmula()
 Dim n As Long
  n = 5
  Sheets("planilha1").Range("A2").Formula = "=SUM(G2:G" & n & ") "
End Sub


[]s
Comentar a resposta do Adalberto27