Excel 2010 - Lista personalizada perde validação de dados [Fechado]

Denunciar
Posts
2
Data de inscrição
quarta 6 de novembro de 2013
Status
Membro
Última visita
8 de novembro de 2013
-
 Edurds -
Boa tarde.
Sou nova no grupo e estou precisando de ajuda no Excel 2010.
Achei na internet esse post que caiu como uma luva para mim.

http://br.ccm.net/faq/13294-excel-2010-lista-personalizada

Mas, está ocorrendo um problema que não consegui resolver. Todas as vezes que fecho o arquivo e o abro novamente a lista de validação de dados deixa de funcionar. Então, tenho que clicar em Dados, Validação de Dados, clicar na formula dentro do campo "Fonte" e depois em OK. Daí a validação volta a funcionar.

Detalhe: Meu Excel 2010 é em português. Tive que alterar os comandos mostrados no post.

DE: = DESLOC (n_regiões;0;0;COUNTA(c_regiões);1)
PARA: = DESLOC(n_nome;0;0;CONT.VALORES(c_nome);1)

DE: = IF(F1<>"";DESLOC(n_regiões;EQUIV(F1&"*";l_regiões;0)-1;;SOMA((STXT(l_regiões;1;NBCAR(F1))=TEXTO(F1;"0"))*1));l_regiões)
PARA: = SE(F1<>"";DESLOC(n_nome;CORRESP(F1&"*";l_nome;0)-1;;SOMA((EXT.TEXTO(l_nome;1;NÚM.CARACT(F1))=TEXTO(F1;"0"))*1));l_nome)


Agradeço imensamente a ajuda de vocês.

2 respostas


Tente tirar os acentos ("til" de regiões, NÚM)
Posts
2
Data de inscrição
quarta 6 de novembro de 2013
Status
Membro
Última visita
8 de novembro de 2013

Obrigada pela resposta. Na minha formula eu alterei a palavra "regiões" para nome... Não tem nenhum acento... Se tiver outra idéia eu agradeço...
bom dia !!! Gostaria de saber se voce encontrou solução para este problema , pois estou com o mesmo ...