Excel 2010 - Lista personalizada perde validação de dados

Fechado
Ksuzana Posts 2 Data de inscrição quarta 6 de novembro de 2013 Status Membro Última visita 8 de novembro de 2013 - 6 nov 2013 às 14:28
 Edurds - 25 jan 2016 às 11:00
Boa tarde.
Sou nova no grupo e estou precisando de ajuda no Excel 2010.
Achei na internet esse post que caiu como uma luva para mim.

https://br.ccm.net/faq/3675-lista-seletiva-com-entrada-semiautomatica-para-o-excel

Mas, está ocorrendo um problema que não consegui resolver. Todas as vezes que fecho o arquivo e o abro novamente a lista de validação de dados deixa de funcionar. Então, tenho que clicar em Dados, Validação de Dados, clicar na formula dentro do campo "Fonte" e depois em OK. Daí a validação volta a funcionar.

Detalhe: Meu Excel 2010 é em português. Tive que alterar os comandos mostrados no post.

DE: = DESLOC (n_regiões;0;0;COUNTA(c_regiões);1)
PARA: = DESLOC(n_nome;0;0;CONT.VALORES(c_nome);1)

DE: = IF(F1<>"";DESLOC(n_regiões;EQUIV(F1&"*";l_regiões;0)-1;;SOMA((STXT(l_regiões;1;NBCAR(F1))=TEXTO(F1;"0"))*1));l_regiões)
PARA: = SE(F1<>"";DESLOC(n_nome;CORRESP(F1&"*";l_nome;0)-1;;SOMA((EXT.TEXTO(l_nome;1;NÚM.CARACT(F1))=TEXTO(F1;"0"))*1));l_nome)


Agradeço imensamente a ajuda de vocês.
Veja também:

2 respostas

usuário anônimo
8 nov 2013 às 10:23
Tente tirar os acentos ("til" de regiões, NÚM)
1

Assine nossa newsletter!

Assine nossa newsletter!