Combinar vários alinhamentos na mesma celula

Resolvido/Fechado
epinho
Posts
8
Data de inscrição
terça 18 de fevereiro de 2014
Status
Membro
Última visita
5 de março de 2014
- 18 fev 2014 às 05:31
epinho
Posts
8
Data de inscrição
terça 18 de fevereiro de 2014
Status
Membro
Última visita
5 de março de 2014
- 28 fev 2014 às 12:08
Bom dia,

Estou a tentar juntar estes alinhamentos na mesma célula, mas sem sucesso:

=IF(A5=Data!$O$21;IF(D5<=1600;Data!G4*83,18175/0,7804305;IF(D5>1600;IF(D5<=2500;Data!G5*83,18175/0,7804305;IF(D5>2500;Data!G6*83,18175/0,7804305)))))

=IF(A5=Data!$O$22;IF(D5<=1600;Data!G15*83,18175/0,7804305;IF(D5>1600;IF(D5<=2500;Data!G16*83,18175/0,7804305;IF(D5>2500;Data!G17*83,18175/0,7804305)))))

=IF(A5=Data!$O$23;IF(D5<=1600;Data!G25*83,18175/0,7804305;IF(D5>1600;IF(D5<=2500;Data!G26*83,18175/0,7804305;IF(D5>2500;Data!G27*83,18175/0,7804305)))))

=IF(A5=Data!$O$24;IF(D5<=1500;Data!K4*83,18175/0,7804305;IF(D5>1500;IF(D5<=2500;Data!K5*83,18175/0,7804305;IF(D5>2500;Data!K6*83,18175/0,7804305)))))

=IF(A5=Data!$O$25;IF(D5<=1500;Data!K15*83,18175/0,7804305;IF(D5>1500;IF(D5<=2500;Data!K16*83,18175/0,7804305;IF(D5>2500;Data!K17*83,18175/0,7804305)))))

=IF(A5=Data!$O$26;IF(D5<=1500;Data!K25*83,18175/0,7804305;IF(D5>1500;IF(D5<=2500;Data!K26*83,18175/0,7804305;IF(D5>2500;Data!K27*83,18175/0,7804305)))))

=IF(A5=Data!$O$27;IF(D5<=1500;Data!O4*83,18175/0,7804305;IF(D5>1500;IF(D5<=2500;Data!O5*83,18175/0,7804305;IF(D5>2500;Data!O6*83,18175/0,7804305)))))

=IF(A5=Data!$O$28;IF(D5<=1500;Data!S4*83,18175/0,7804305;IF(D5>1500;Data!S5*83,18175/0,7804305)))

=IF(A5=Data!$O$29;IF(D5<=1500;Data!S12*83,18175/0,7804305;IF(D5>1500;Data!S13*83,18175/0,7804305)))

Tentei esta opção:
=IF(A10=Data!$O$21;IF(D10<=1600;Data!V3;IF(D10>1600;IF(D10<=2500;Data!V4;IF(D10>2500;Data!V5))));IF(A10=Data!$O$22;IF(D10<=1600;Data!V6;IF(D10>1600;IF(D10<=2500;Data!V7;IF(D10>2500;Data!V8))))))


Até dois alinhamentos funciona, mas quando tento adicionar o 3º, diz "you've entered to many arguments for this function."

Alguma sugestão?

Abrigado

7 respostas

Mazzaropi
Posts
1965
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
18 de setembro de 2022
584
21 fev 2014 às 16:04
Prezado Eduardo, Boa Tarde.

Recebí a sua explicação e o arquivo, mas estava com alguns assuntos para resolver por isto não lhe respondí antes. Me desculpe.

Verifiquei os seus exemplos e estranhei alguns resultados.
Pelo arquivo que eu tenho aquí comigo os valores do TX não são possíveis.
A não ser que você tenha modificado algum indicador de percentual na SUA planilha e fez os exemplos com ela.

Baseado na planilha que eu tenho aquí comigo que você enviou, o que acontece é que quando você copiou a fórmula da célula W3 e da célula Y3 e aplicou nas demais células abaixo, você esqueceu de alterar a célula de origem da pesquisa.

Portanto TODAS elas estavam referenciando-se à célula D5. Isto funcionava para a primeira ocorrência que era LP
MAS... quando passavas para a próxima ocorrência LACC a célula deveria ser a D6 e na fórmula AINDA constava a D5.

O que eu fiz:
a) Alterei na aba DATA as fórmulas dos ítens LACC e LASC para lhe mostrar que deste jeito funciona.
Agora é só você fazer o mesmo com os demais ítens.

b) Coloquei um adendo na fórmula da aba MOTOR TEMPLATE nas colunas J e K para somente executarem os cálculos quando houver o preechimento da coluna D Cilindrada CC. A planilha fica mais limpa e organizada assim.

c) Troquei a fórmula da aba MOTOR TEMPLATE na coluna L:
De...: =J5+K5
Para: =SOMA(J5:K5)

Segue a sua planilha com estas pequenas modificações:
http://speedy.sh/HPAaK/20-02-2014-Simulador-Auto-teste-OK.xlsx

Era isto que você precisava para continuar o seu trabalho?
Espero realmente ter ajudado você.
--
Belo Horizonte, Brasil.
Marcílio Lobão
1
epinho
Posts
8
Data de inscrição
terça 18 de fevereiro de 2014
Status
Membro
Última visita
5 de março de 2014

24 fev 2014 às 06:09
Prezado Marcílio
Ainda continua a ter alguns erros como explico no exemplo que se encontra no seguinte link

http://speedy.sh/3X7nu/Picture1.png

envio também a planilha completa para que tenha uma ideia mais completa da mesma

http://speedy.sh/GWXCH/Simulador-Auto-Global.xlsx

Obrigado

Eduardo Pinho
0
Mazzaropi
Posts
1965
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
18 de setembro de 2022
584
24 fev 2014 às 13:56
Prezado Eduardo, Bom Dia.

Pela sua resposta:
"...Ainda continua a ter alguns erros como explico no exemplo que se encontra no seguinte link..."

Eu imagino ou que você não leu a minha mensagem e observou a planilha que eu lhe enviei ou que eu não expliquei tão bem como deveria.

Vamos novamente:
"Baseado na planilha que eu tenho aquí comigo que você enviou, o que acontece é que quando você copiou a fórmula da célula W3 e da célula Y3 e aplicou nas demais células abaixo, você esqueceu de alterar a célula de origem da pesquisa.

Portanto TODAS elas estavam referenciando-se à célula D5. Isto funcionava para a primeira ocorrência que era LP
MAS... quando passavas para a próxima ocorrência LACC a célula deveria ser a D6 e na fórmula AINDA constava a D5."

Estou baixando e alterando a sua Planilha Completa.

IMPORTANTE:
A permanência da ordem das REF na coluna A é fundamental para que a sua tabela funcione.

ALTEREI as células de referência na aba DATA na coluna W

Observe:
Motor Template.....DATA
A5 --> LP.................W3 ----> =SE('Motor Template'!$D$5<=1600................
A6 --> TX.................W12 --> =SE('Motor Template'!$D$6<=1500................
A7 --> LACC...........W6 ----> =SE('Motor Template'!$D$7<=1600................
A8 --> LASC...........W9 ----> =SE('Motor Template'!$D$8<=1600................
A9 --> CP+..............W26 --> =SE('Motor Template'!$D$9<=1500................
A10 --> MI...............W18 --> =SE('Motor Template'!$D$10<=1500................
A11 --> CP3,6.........W21 --> =SE('Motor Template'!$D$11<=1500................
A12 --> CP10,0......W24 --> =SE('Motor Template'!$D$12<=1500................
A13 --> TXC............W15 --> =SE('Motor Template'!$D$13<=1500................

Baixe a sua planilha completa abaixo, que eu alterei, e faça os testes.
Testei aquí e está tudo em perfeito funcionamento.
http://speedy.sh/j7X3E/24-02-2014-Simulador-Auto-Global.xlsx

MUITO IMPORTANTE:
Para que a sua tabela continue a funcionar é imprescindível que a sua coluna A permaneça na mesma ordem das REF.
LP; TX; LACC; LASC; CP+; MI; CP3,6; CP10,0; TXC

Isto acontece porque a sua tabela na aba DATA tem um problema estrutural na montagem.

SE, você precisar que a cada momento possa colocar as referências de qualquer maneira, então será necessário mudar o lay-out da tabela completamente. Igual eu sugerí na primeira mensagem que lhe respondí.

Faça os testes e me diga se está como você precisa.

Espero ter ajudado.
-----------------------------------------------
Belo Horizonte, Brasil
Marcílio Lobão
0
epinho
Posts
8
Data de inscrição
terça 18 de fevereiro de 2014
Status
Membro
Última visita
5 de março de 2014

26 fev 2014 às 06:10
Prezado Marcílio, bom dia,
Sinto que já estou dando trabalho demais.
Eu fiz efectivamente o que referiu e alterei a céclula de origem, contudo, e depois da sua ultima informação "IMPORTANTE: A permanência da ordem das REF na coluna A é fundamental para que a sua tabela funcione." Eu acredito que o erro que me continua a dar esteja nessa questão e que efectivamente posso ter de mudar o layout da tabela, mas não estou vendo como (sou apenas um curioso no que diz respeuito a Excel).

Envio mais umas imagens para ver se consigo fazer entender o que pretendo. Se tiver alguma sugestão, agradeço, caso contrário, também agradeço.
Efectivamente, voçê tem sido muito atencioso, e já valeu pelo que já aprendi.

Aqui seguem os links para as imgens:
Imagem 1: http://speedy.sh/mzTqN/sim1.png
Imagem 2: http://speedy.sh/6xa8n/sim2.png

Mais uma vez, grato pela paciencia.
Abraço
Eduardo
0

Assine nossa newsletter!

Assine nossa newsletter!