Formula no Excel [Resolvido/Fechado]

Posts
3
Data de inscrição
terça 18 de fevereiro de 2014
Última visita
19 de novembro de 2014
- 18 fev 2014 às 12:46 - Última resposta:
Posts
3
Data de inscrição
terça 18 de fevereiro de 2014
Última visita
19 de novembro de 2014
- 19 nov 2014 às 12:08
boa tarde, não estou conseguindo concluir uma formula no excel, onde digitando um numero (codigo cliente) na coluna B de uma planilha, vai buscar esse numero (codigo cliente) em outra planilha que terá na frente (coluna C) o nome do cliente e o copiará, colando na planilha inicial também na coluna C

Exemplo:
Planilha A Planilha B

a ser digitado serve de fonte para planilha A

col B col C col B col C
copiar
digitado colado da planilha B verificado 7695 Washington de Tal
7695 Washington de Tal

Resumo: digito um codigo na plan A e ele busca esse codigo na plan B e copia o nome referente esse codigo na plan A
Ver mais 

4 respostas

Posts
1834
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
30 de maio de 2018
- 18 fev 2014 às 22:51
0
Obrigado
Toninhobeb, Boa Noite.

O que você está relatando que está acontecendo na planilha não combina com o que a fórmula da célula B2 da Sheet1 faz.

A fórmula é: =PROCV(A2;Sheet2!A2:B6;2;FALSO)

Dissecando a fórmula:
a) PROCV ----------> A função procura na vertical na 1ª coluna do intervalo.

b) A2 ----------------> O código da Sheet1 que será procurado na 1ª coluna da Sheet2.

c) Sheet2!A2:B6 -> Este é o intervalo de pesquisa. coluna A de 2 a 6 e coluna B de 2 a 6. Isto equivale aos 5 códigos presentes no exemplo.

d) 2 ------------------> Vai trazer como resposta o conteúdo da segunda coluna.

e) FALSO -----------> Isto quer dizer que ele trará o nome SOMENTE se encontrar o valor EXATO igual ao A2 da sheet1, INDEPENDENTE da classificação ou ordem na coluna.

Logo, qualquer um dos códigos existentes na tabela da sheet2 que for digitado na célula A2 da sheet1 trará o nome correspondente.

Observe que se você colocar os 250 códigos como você disse que tem, na sheet2, o intervalo deverá ser alterado na fórmula, claro.
Se forem colocados 250 códigos na sheet2 a fórmula na sheet1 deverá ficar:

=PROCV(A2;Sheet2!A2:B251;2;FALSO)

A ordem númerica dos códigos não tem nenhuma importancia para a pesquisa.

Se após ler esta explicação você verificar que a planilha continua dando este comportamento mande um exemplo para mim.
Vamos resolver esta questão e solucionar a sua necessidade.

Aguardo resposta.
Belo Horizonte, Brasil.
Marcílio Lobão
Posts
3
Data de inscrição
terça 18 de fevereiro de 2014
Última visita
19 de novembro de 2014
- 18 nov 2014 às 22:08
0
Obrigado
Meu amigo, perdoa-me a minha ausência e por não ter dado a resposta para essa formula, se deu certo ou não. Mas foi porque eu tinha muita prioridades a resolver, e essas planilhas fui digitando manualmente mesmo, infelizmente.
Marcilio, se vc tiver um tempinho para reservar para mim te agradeço imensamente.
Portanto como faço para te mandar as duas planilhas ? acho que assim será mais facil.

Obrigado,
Toninhobeb
Posts
1834
Data de inscrição
segunda 16 de agosto de 2010
Status
Contribuinte
Última visita
30 de maio de 2018
- 19 nov 2014 às 11:22
0
Obrigado
TONINHOBEB, Bom dia.

Salve as suas planilhas no site gratuito e sem necessidade de fazer cadastro, www.speedyshare.com e coloque o link para download aquí.

Lembre-se de colocar dados suficientes nela para que seja possível entender corretamente a sua necessidade.

Coloque alguns exemplo de como deveria ser a resposta esperada.

Fico aguardando os links.
--
Belo Horizonte, Brasil.
Marcílio Lobão
Posts
3
Data de inscrição
terça 18 de fevereiro de 2014
Última visita
19 de novembro de 2014
- 19 nov 2014 às 12:08
0
Obrigado
Segue o link que vc pediu

http://speedy.sh/BWtW5/VENDAS-EM-PECAS-2014-MORALES.xlsx

obrigado,
Toninhobeb